Input field Integer is not validating

Hi there,

Wonder if someone can help with this issue?
Trying to create an item with one value as number. I uses input field integer, but it keeps getting invalid entry. Someone know why? :pray: :pray:

Annotation 2019-12-19 013051

try decimal…I don’t know why integer is not working, as it should, but try decimal to see if it works or not.

Otherwise I’d say file a bug report.

Hi Boston85719,
Thanks for checking. I’ve tried on mac and windows, both had an issue. Tried decimal too, still does.
I am in development mode.
Once I unchecked “This input should not be empty”, the field validation works but when the record is saved, it didnt save any integer even there is a value entered.

Wondering am I missing something…



Hey Boston,

I have tried again. It works now. I went to checked on other apps, it didnt had the issue.
I went back to the same app, other pages and tried creating another input. It worked. Copied and paste on my reusable element, apply the same workflow and styles, somehow now it worked.

Not sure what’s the difference but glad it does.

Thanks anyway!

1 Like

Did you happen to have used the “replace” feature on the element editor?

There is the ability to basically change the type of element.

Screen Shot 2019-12-19 at 2.12.59 PM Screen Shot 2019-12-19 at 2.12.50 PM

In my experience what this does is basically breaks the element…meaning that it doesn’t function as it should, so my thought is if you had done that, it could be the reason the input didn’t work properly.

Otherwise, I don’t know what is the real cause, except that I have experienced head banging moments as well and unfortunately the solution is to delete and rebuild.

Yes Boston, deleted and rebuild a few times through many permutations before it works.
Don’t remember whether I replaced that element before.

Thanks for your sharing!

This topic was automatically closed after 70 days. New replies are no longer allowed.