Forum Academy Marketplace Showcase Pricing Features

Input initial content dynamic data not displaying when linked to another input

I can’t get this to work but it seems like it should.

I have three inputs, Inches, Feet and Centimeters that are referencing each other for dynamic initial values. The idea is the user could have the length in any of the three units but wants to see the conversion to the other two once the unit they have is entered.

Why doesn’t Feet update when Inches are input?
Inches and Centimeters Update when Feet are entered.
Inches and Feed update when Centimeters are entered.

Forum App

It seems like it should work, but I must be missing something. I changed the order of referencing around and get a different input not updating.

Ok, I messed around with this. What’s happening here is that the initial content will really only change until the input itself is modified. There were actually other combinations of inputs that resulted in nothing happening, like if you tried to change feet/cent again after they worked, eventually they wouldn’t.

My #1 suggestion to make this work WITH the inputs is to save to the database, but there are likely many reasons you don’t want/need that. Otherwise, use custom states. I’ve modified your example to demonstrate and it seems like it works no matter where you input nor how many times. I added pauses to ensure the states get updated in the right order since other actions rely on those updated values. The way to remove the pauses though is to just use different formulas based on the input being changed, but I left as is to demonstrate the process and keep your formulas. Ex: when inches is changed, custom states for feet and centimeters are changed based off inches; when feet is changed, inches and centimeters are changed based of feet, etc.

Hope this helps.


Gaby | Coaching Bubble

2 Likes

Thanks Gaby for the workaround suggestion. I believe I actually could get initial content to subsequently change after the input itself was modified. Do you think this inputs should have changed as I expected them to or is it just behaving as it should?

I was hoping to avoid the workflows and sending to the database for this because I actually need a total of around 15 columns of the three inputs that the user will be manually adjusting until a calculation based on the inputs balances. Once the user is good with the adjustments, then I was planning on sending the data to the database with one workflow. With using workflows to do the conversion I’m concerned that the workflow quota will be eaten up really fast.