Forum Documentation Showcase Pricing Learn more

Insert dynamic data support

I’m really struggling with the ‘Insert Dynamic Data’ workflow. The optional paths aren’t consistent (sometimes it will let you use an ‘=’, sometimes you have to use ‘contains’ and it seems to be completely different rules on the workflow vs. design pages. I love bubble, but actually getting to the data I want is making me want to throw things and hurt people.

Is there anyplace outside of Bubble’s documentation that has a better explanation?

Is there someplace I can get a translation to SQL so I can understand what it’s trying to do?

I’m trying to do a lookup and pass it through the url. I have a table with zipcodes (Zips). That table is joined to the Zones table - a zipcode can only be in one zone. User inputs a zipcode and I want to pass the name of the zone that the zipcode is in. Should be a very easy lookup.


This returns nothing - the conditional works, and the zipcode lookup works. But nothing is passed.

Any advice?

Can you show your setting for zone search?
Also. You said that zipcode is linked to Zone (in this direction or Zone is linked to Zip?)

Thanks for replying.


I’m not sure how to ‘show my setting.’ I’m frustrated at not being able to see what’s actually happening.
zone_name is of type Zone, and it seems to get that.
I’m also trying to just add this info to the current user to make it easier to transfer info, but I’m not getting any luck there either.

What I’m trying to do is: ‘do a search in the Zip table and return the zone_name where the ZipCode equals x.’

You are passing the Zip code already and you should just pass this to the other page. In this page, You should Get the Zipcode and because zone is already related, you can just use the informaiton from zipcode DB.
To show your search setting, You can just click on Search and this will popup the search window.
What you can do is to share your app editor link (be sure to enable public in settings).

According to your screenshot, Zipcode is a number field, but this should be a text field. Even if they are number, a zipcode should be considered like a string.

Thanks. I haven’t changed the zipcode because that seems to be working. I tried for about 2 hours to lookup the zone from the next page, and finally gave up. Now trying to find it in the first page and pass it.
I opened up shared view - should I share the link here or DM?

DM if you prefer