Ipiphy bug? On page load sequence, then change user thing does not work

Need confirmation if this is a bug. Pretty sure it is. If you make get value from API Ipiphy and then the next thing you do is to Make Changes to Thing (users).

Then the changes are not made. You need to check the database as value are appear (somehow) as if they are available. But the are NOT in the database.

To replicate:

In the PAGE LOADED WORKFLOW

  1. Set state of something to the IP address
  2. Save the IP address to the User table in a field called something like My IP.
  3. Load page
  4. Check user table directly in the editor

Strange behavior is as follows:
If you query User My IP in that page you get the correct value. But it was never saved to the database nor can be viewed in any other page. I checked permissions. Added all kinds of other test and variables and confirmed this behavior.

Thanks. Can you submit a bug report and we’ll take a look.

will do

Thank you @neerja for sticking with me on this ‘bug’ and suggesting workarounds and wanted to share the findings.

I have the following conclusions:

  1. If you use the Ipiphy API via a workflow it returns IP value of the Bubble server. Not what I was looking for.
  2. If you use the Ipiphy API in a workflow subsequent database actions in the workflow will not work. (This is the bug).

Workaround:
Call the Ipiphy API from the conditional of an object. But this will likely require user action to do anything with it. Keep the value in a state, then you can work with it.

Thanks again @neerja. Fixing this bug is no longer relevant to me but might help others.

1 Like

I have the same problem. Why on earth is the bubble server IP returned on a workflow??? Why on earth isn’t it on the documentation as a MAJOR bug ??? This is the most basic (only) feature of this plugin and it is just not working, and 1 year or so later the bug is still not fixed. Despite some promising features, every day trying to use Bubble is an additional pain… :disappointed:

Thanks a lot @mente12 for having spotted the issue and provided a workaround

What workaround did @neerja provide besides the one I provided above?

Answer: Just saw your change above…

Rick
@mente12

Sorry @mente12 I meant your name instead of neerja’s, I mixed the names (little tired) I modified my reply :slight_smile:

1 Like

It seems like this bug hasn’t been solved?

When the user signs up, I save the user’s IP address to a text field.

It worked in development during a workflow (it allowed the user to sign up and the user’s ip address was recorded in the development database), but as soon as I tried it on a live version, it said “Unable to connect to Ipify: Error connecting to Ipify (0)” and the user can’t sign up.