Forum Academy Marketplace Showcase Pricing Features

Issues with Bubble Recognizing JSON from API (Keepa)

Hey guys!

First of all, thank you! I’ve learned so freaking much from everyone here, don’t know what I would have done without everyone’s posts!

I’ve dug through every single API related post I can find here and can’t quite seem to find my type of issue. I’m having issues connecting the Keepa API to bubble (https://keepa.com/#!api for docs). When I try to initialize the following example call, I get the following error every time.

And I get…

50%20PM

Works great in postman, not sure what’s going wrong. The JSON parses perfectly.

I even tried doing a straight up call with the parameters hardcoded into the URL, but no dice again. Same error.

Even tried this exact URL directly in the browser and it works great.

I’ve tried several other available calls and they all work in postman and the browser (and google sheets script), but none will work on bubble with the API connector.

Anyone have any ideas on how to fix this, or any other suggestions to get around this problem?

Thanks in advance everyone!

Hi, I am new to this and trying to use the script editor on google sheets to pull data from keepa. Do you mind sharing your code for how you did that?

Thanks!

Has anyone figured out a way to get the Keepa API to work in the API connector?

If Im correct you would need to add to the header:

Header:

Key:Accept-Encoding Value:gzip,

I believe the support was built in to API Connector back in August 2019

Doesn’t seem to fix the issue.

I have read post that is attached above again and it seems like that Bubble should do the encoding automatically without the header. Do you get the error : the returned object is a text not json without the header?

Hi everyone, just launched a new keepa plugin if you’re interested.