Forum Documentation Showcase Pricing Learn more

Issues with uploading CSV - Taking way too long to upload

I have a CSV file that has 100-200 rows and it is taking bubble upto 10 to 15 minutes to upload everything. Sometimes an error message that says “Operation Timed Out --app too busy” comes up.

I initially thought it has something to do with my workflow so I removed all actions and just made a single button that uploads the CSV file but the upload speed is unchanged.

My internet speed is 100 mbps. I upgrade my plan from Personal to Professional to Team thinking it wil improve the speed but nothing is unchanged so far, despite the plan clearly saying that it can upload 1000 rows of CSV in runtime without any issue.

bumping this post. My issue is still not resolved and I am hopeful somebody can point me to the right direction.

Desperately need a solution for this.

I have a user that needs to upload csv data (100 rows) but keeps timing out. I have moved this upload process to a workflow API but still an issue. I have upgraded to the Professional plan but this is still an issue.

PS. Uploading 4 records from a .csv takes 2 minutes on a Professional plan - ludicrous.

@emmanuel, any workaround to have data from csv imported instantly would be greatly appreciated!

Thanks,
Pete

I’m running into the same problem. I have a recursive API workflow that uploads multiple CSVs (each one has 60 rows) one after another. It completes the first upload but times out a few minutes after the second upload starts. I’ve tried uploading each file individually and it works fine but not in a recursive workflow called from a list of CSV files.