Login not recognizing email

I’m using Bubble’s built-in login feature set and it’s worked for weeks. Just now, I tried signing in and I’m getting an alert that I need to enter an email (even though I have and it’s one that exists in my database already—changed for privacy in my screenshot):

That means no one can log into my app right now, which is obviously bad.

Things I’ve tried:

  • I have both login fields set as “This input should not be empty” though I’ve also tried unchecking this to see if it fixes anything (it hasn’t).
  • I’ve checked that it’s not a casing issue with the email and the email is formatted correctly as an email.

The only other change I can think of that could affect things is that I changed my domain name, but everything else seems to be working as expected (just logging in is having issues).

What does your WF look like when logging in the user?

What do you mean by WF?

Workflow

please check your input name and within the workflow name both name should same.
please change your input name and try again

It’s just the standard, out-of-the-box “log the user in” Bubble workflow:

Double check you’re referencing the right email input and password input

Ah, yep, that was it! I don’t know how that got mixed up but did some better naming and it’s working now. Thank you!

2 Likes

This topic was automatically closed after 70 days. New replies are no longer allowed.