Maps Zoom differs normal run vs. step by step

Hi there,

Not sure if it’s a bug or my incompetence but here is today’s problem for me:

I have a page that displays up to 3 locations on a map (each in a data type “MeetupPoint” that belongs to a “User”). Each MeetupPoint’s location can be edited in an input box.

When a location input is modified (autobind but specific workflow for zoom adjustement - among other actions that are irrelevant here), either of the two happens:

  • If there is only 1 MeetupPoint for this User, zoom manually to the User’sMeetupPoint’sLocation with zoom 15.
  • if there are more than 1 MeetupPoint for this User, zoom.

I tried to test all this. When I have 1 MeetupPoint and add another one (in the second input box), this works well when I do this in the debugger step by step or “run slowly”. In “normal mode”, this zooms very closely to the second MeetupPoint’s Location.

Did someone encounter such issue? Any clues as to what could be messing up here?

Here is the page (login with username/pwd: test/test) if any of you doesn’t mind having a look:
My App

@jayborders had a similar problem (relating to RepeatingGroup unlike me):

normal vs slow or step by step

solved with a delay timer of 250ms before the zoom adjustement, although maybe not a consistent and reliable workaround.

1 Like

This topic was automatically closed after 14 days. New replies are no longer allowed.