Missing control: "Height for UI builder"

The new responsive engine lets me define a “Width for UI Builder” on a page, which sets a preferred working area. Nice!

There is however no “HEIGHT for UI builder”. Why?

There is a “Min height” option, and I can set that to fit my elements, but it has real life implications (I found out the hard way, chasing a “bug” on mobile view for hours) and not merely a thing for the builder itself.

Omitting this option instead pancakes any item not being fixed height at a higher level, making the editor impossible to work with.

Am I the only one who has noticed this yet? Anyways, upvotes for the team to consider this if they have not already.


Thanks for posting this Alex! I thought there’s already a way to fix this but apparently not.

I also have the same question because I am making a dashboard and also having a hard time on getting the height to full screen right without forcing it using the Min height mentioned above.

1 Like

Having the same issue. I want to set my min height to 0 (which it technically is), but that causes my editor interface to become 0px tall…not very nice for development :frowning:

1 Like

Same issue here. When you working with floating groups as the main groups on your page than you have to edit on a blank canvas with no height. Would be great is there was an option: height for UI builder or an option to set the height to max display height.

1 Like

Big +1 for this. Not having this option is a real pain, my app relies on scaling elements to viewport height and I’ve got to remember to reduce the height after editing everytime I deploy any changes so I don’t break my app.