Forum Academy Marketplace Showcase Pricing Features

Mobile Version not opening on Mobile

Not sure if others are experiencing this, but all my apps are responding the same on mobile versions of desktop pages.

My Desktop pages have mobile versions for all pages. For some reason when I open the link on my mobile it does not open the Mobile version, but opens the desktop. Was working fine until now.

Does anyone else have this problem?

4 Likes

Same here, a lot of apps with mobile version page addressed from index don’t work, some apps are in App Store/Google Play and now look weird.

1 Like

@emmanuel do you perhaps know if there is an issue we should be aware of?

Thank you for assisting.

I am experiencing this issue as well! Would you know how to report this to bubble?

Same here. Need this fixed asap. @jan1 logged a support ticket too. Also, stated marketing the service today! Perfect timing :confused:

1 Like

@ervinn.tangco logged a support ticket. Have to wait for feedback, but this bad for my live app at the moment. It’s only started today so something had to change on bubble that we were not aware of.

1 Like

Same here… just experienced this today and no updates or tweets on bubbles side yet. I hope this issue is fixed soon

Hey @ervinn.tangco

You can report a bug here: Bug Report | Bubble

Probably related to this release:
11/03/21 12:18
Small fix for hidden mobile version setting still being applied in native apps

Seems like some bad code was pushed. @bubble

Hope that helps! :blush:

@j805 www.NoCodeMinute.com

For All Your No-Code Education Needs:

1 Like

Implemented the following workaround: When Page is Loaded (only if page width < 760) → Navigate to pagename_mobile
image

2 Likes

Thank you :pray:t3:

Hi everyone. There was a bug fix that went out earlier today (mentioned above) that fixed an inconsistency that allowed both “This page is a native app” and a mobile version of the page to be selected at the same time. In normal circumstances, the mobile version dropdown should not be an option when “This page is a native app” is checked because this setting is meant only for pages that are going to be wrapped by Cordova. Thus, it would be redundant to have a redirect to a mobile web version of a page that is a native app. The fix above was meant to fix that bug. We are sorry for any confusion/trouble this change has caused, especially since our docs don’t make the intended behavior of this setting clear.

For pages that are no longer redirecting to the mobile version, please check if the setting “This page is a native app” is checked. When unchecked, the mobile version page dropdown should reappear and your app should redirect when viewed on a mobile browser just like before.

Similarly, if you are relying on the unintended functionality (i.e. both “this page is a native app” and a mobile page version set), please let us know so we can address accordingly.

2 Likes

“this page is a native app” is unchecked and it still isn’t redirecting user to the mobile page. :confused:

Hello,
it’s still dont work, i have “this page is a native app” is unchecked and all pages mobile redirecting are broken… please can you check and fix that ?

Rightnow i do " Page is Loaded (only if page width < 760)" but it’s not a solution with a lot of workflow and pages… realy hope this issue will fixed soon!

Thanks for the quick response. There was a bug in the above bug fix, the patch for that should be out very shortly. Do you mind checking again in 10 minutes? Sorry again for the trouble!

1 Like

It’s fixed, thank you for your quick support !

Im not sure if this issue is related or not …

Creating a new native app (0 users in the database). I have a simple workflow to sign up the user:

The logged out text is conditionally showing the I am logged out right now. Although when I click “signup” I get this alert:

Difficult to say if it’s related or not, though I’d say it’s unlikely. If you continue to have trouble with this, please file a bug report and our success team will be happy to help.

Thanks @nickc Nick. Problem solved now. :+1:t2:

1 Like