Multi-select dropdown thing problem

Hi all!

I have a thing called “02 Analyse pakketen” containing simple information as AnalyseCode and AnalyseNaam (name):

in my app you can select 1 or more “AnalyseNaam”:

I have to send these selected 1 or more “AnalyseNaam” as 1 or more “AnalyseCode”
That’s exactly the problem… I can’t send them as AnalyseCode to the API…

I have tried this, but there is no option to select the “AnalyseCode” it is only the actual “AnalyseNaam” text field:
Schermafbeelding 2020-10-29 om 19.22.15

I also have tried to do a search, and that will find the “AnalyseCode” if there is only selected 1 “AnalyseNaam”. If selected 2, the value is empty…:

Any help is much appreciated!

You’re probably setting the “Type” of the multidropdown to “text”. You should instead set the type to “02 Analyse pakketen”, then set the multidropdown’s label to the AnalyseNaam field. Then Multidropdown Selecteer 1 of meerd’s value should result in an 02 Analyse pakketen which you can further use to reference the code using “…'s AnalyseCode”

Thanks @austin3!

that solves the problem!