Multidropdown Is Empty

Hello. I’ve been trying to master the Multiselect Dropdown since it has a lot of potential, particularly when filtering repeating groups.

My issue is that I cannot get it working with any dynamic data. The results keep showing up as blank.

As an example, I setup a multidropdown as follows:


In my database, I have a custom datatype called Teams, and it has attributes, such as name and logo.

When I hit preview, this is what I see:


I cannot see any results, no matter what I type. What’s worse, is that if I delete everything from the search box, then the following happens:


It’s like a list of blank items, and they are clickable:


^This is what happens when I click on one of those blank items.

I’ve tried repeating the above process by using the Team names, like so:


But that does not change the outcome. I’ve also tried changing the source to a repeating group, but that did not help.

I confirmed that the Team data exists (there are over 100 entries), and is usable throughout other parts of my app.

Thanks in advance for anyone’s insight into this. I don’t doubt that I’m missing something obvious.

You’re on the right path. Just need a few things:

  • Keep the “Type of choices” set to Team, not text.
  • For option caption, this needs to have some value. Most likely “Team name” (which is text). That way you have content to show in the box.
  • Be sure to specify a maximum number of items that can be selected

The “search” aspect of the Multi dropdown is based on what is specified in the option caption.

Your search should look something like this:

Dan (creator of LearnTo - 15+ hours of Bubble tutorials and live coaching)

1 Like

@dan1 Thanks for the response.

I did that in the first example above. I only changed it when trying different fixes.

This was the key! When I inserted a static placeholder value, then that placeholder value was used for every option. When I changed it to a dynamic value, Current option (which was the only possible choice), then it worked!

Agreed. I tried multiple values just to make sure this wasn’t an issue.

Thanks for this. Not sure why Option Caption isn’t required.

Appreciate the time.

@jahb304 - happy to help. I’d agree that it makes sense that Option caption should be required.

@Bubble team - similar to the “Field to search” component of a search box requires that a field be specified, would you consider making “Option caption” a required field for the multi dropdown? (I’ve seen this issue come up a few times).

@dan1 thanks for the suggestion. We just put it on the list of things to do. I’ll reply to this thread when it’s done.

@jahb304 thanks for the OG post