My app is not accessible without the "www" prefix

Hello everyone,
Everything seems to be good on my side, but for some reasons, when I delete the “www” from the url I get a 403 forbidden error (from cloudflare apparently).
I added all the entries that I was supposed to add within the DNS, and I have no error messages in Bubble.
Am I supposed to do something ?

I hope someone might be able to help me,
Thanks,
Robin

To allow visitors to access your website without typing “www” in the URL, you need to set up a DNS record that redirects requests from the root domain (e.g. example.com) to the “www” subdomain (e.g. www.example.com).

Here’s how you can do it:

  1. Log in to your domain registrar or DNS provider’s website.
  2. Look for the DNS settings or DNS management section.
  3. Create a new DNS record of type “CNAME”.
  4. In the “Host” field, enter the root domain (e.g. example.com).
  5. In the “Points to” field, enter the “www” subdomain (e.g. www.example.com).
  6. Save the DNS record.

This will redirect all requests made to the root domain to the “www” subdomain, allowing visitors to access your website without typing “www” in the URL. Keep in mind that it may take some time for the DNS changes to propagate, so it may not work immediately.

Thanks for the help @williamtisdale !
I tried it but unfortunately it still show the 403 Forbidden error (Iwanted two days for the DNS changes to propagate).

I still on’t understand something, why should I use another DNS record while bubble’s doc only mention four A record ?

Thanks,
Robin.

What did you put into the domain field on bubble?

Hi @NigelG,
On bubble I put the domain with www.

I think I might have a problem with my DNS entries. Should I input something on the host part ? @ or * or should i just leave it empty ?

Thanks, Robin