My "Create an account for someone else" does not work

Hello everybody,
I don’t think I can’t do something that simple.

I created an account for another user with a reset password sent by email.
The user receives the email and changes their password.
This directs him to the log in page, and when he writes his email and password, it doesn’t work.

The error message is: “We did not find an account with those login credentials
And yet, there are email addresses in the User database.

There is a photo of the “create an account for someone else” below.

But why doesn’t it work?:exploding_head:
Thank you

Hi there, @thomascope… if the user receives the email and is able to reset their password, then your creation of an account for someone else appears to be working. Are you able to see the user in the User data type and have you tried using the Run as feature to see if you can run the app as that user? If that works, then it seems like the only thing left is that the user is typing their email and/or password incorrectly when they attempt to log in.


Hello Mike,

Tha’s why I become crazy because:

  • The email s correct, i double-double-triple-quadraple checked and the user receive the email

  • The User (Me for the test) reset the password with only one letter thus impossible to make it wrong;
    Screenshot 2023-12-30 at 18.50.21

Then, the user has witten the email adress and the password but there is the same error message:

So I checked on my database and the user is here (

So I ran as this user in another page inside th app, and it works;. So Why when the user wants to log in, there is this error message ?

And it is crazy because, the user that has created the account with a sign up is working.

Is there something wrong ?

I’m guessing this isn’t it, but any chance it’s a difference between the development and live databases (that is, the user is being created in one but trying to log in to the other)?

Yes it is in the database look the image below :

Screenshot 2023-12-30 at 19.32.12
It is the account created with the workflow “Create an account for sometone else” and I cannot connect on the app because the error message when I want to log in. and
They are the account created with the sign up workfloiw and I can connect on the app when I log in.

I don’t understand what s happening

That reply doesn’t answer my question… I asked about it possibly being a difference between the development and live databases.

Sorry I misunderstood.
What donyou mean ?

What is thé différence between développment and live databases ?

Where do we Check It ?
This is about this topic?

So Should I deployed to test if the log in is working for thé created account by another user?

But after i deployed it, could I modify my app ? Front end and workflow and database ?

Or if not, how could I test if the log in is working ?

Sorry i am lost :slight_smile:

I read your previous reply, and given that those three users are in the same database and two of them work and one of them doesn’t, it is unlikely to be a database discrepancy anyway. At this point, I’m not sure why it’s not working. I assume the password change is being confirmed as successful when the password reset is performed, right?

1 Like

Indeed, the users that you see in the database and work, are the users created with th Sign up workflow.
With the workflow “Created an account for someone else” does not work.

I think it works when I reset the password because when I click confirm, the app go to the page Log in. You can see on the image below. the debugger step-by-step:

what do you think ?

You don’t have a Reset password action in that workflow, so the password isn’t being changed… you are simply taking the user to the login page when the button is clicked. Did you make that form or are you using Bubble’s built-in reset password page?

1 Like

I took the page that Bubble propose for the reset password. And below I took some screenshot on my workflow (I think after you see it, you will hate me ^^)

Screenshot 2023-12-30 at 20.32.40

Should I add ?
a step for reset password
and a reset for an update Update the user’s credentials

Thank you

This is what the workflow looks like on Bubble’s reset password page, so I guess you deleted the Reset password action? I don’t know why you would have done that, but that’s why it is not working.

Mike !

I did it !!! and it thanks to you!
I don’t why I deleted the workflow with th reset password but you found the solution
I learnt about development and live database!
So I won today and it thanks to you

I really appreciate your time :slight_smile:
Happy new year !!!

1 Like

This topic was automatically closed after 70 days. New replies are no longer allowed.