mySQL SQL query with LIMIT 10 generates popup error when initializing query

I cannot initialise a basic select with a LIMIT 10. Error pop up ‘Please limit the query to at most 200 entries’.

Is there something I am missing: My query working in MySQL Workbench and brings back the 10 rows but the front end doesn’t seem to recognise the LIMIT clause.

1 Like

Can you share the query you’re running?

select column_name
from table_name

where column name is a actual column and table_name is the actual table name.

I get the same issue, just didn’t realise it before! On my own database MySQL version 5.5.52-0+deb8u1

The limit works when I connect to the “employees” database in @georgeciobanu 's example on MySQL version 5.6.28-0ubuntu0.15.10.1 …

select * from employees limit 2

EDIT: spoke too soon, the limit is working on both databases … my other test had an additional filter.

select *
from fabrics
limit 10;

This is still generating a “Please limit to at least 200 records” pop up message. Please help.
I am able to access my database which is hosted on AWS via MySQL Workbench locally on my machine so there is no connection issues. The SQL I have wrote is valid and produces the correct results as per the LIMIT applied.

Does it work without the semicolon?


No, tried with and without :frowning:

I just tried with newlines like yours, and got the same error message.
Try it all on one line:
select * from fabrics limit 10


You are a star! that worked, I can move forward :slight_smile:
Thank you for taking the time to reply.

1 Like

This problem still exists…

I get the issue with this command:
SELECT topicID FROM mydb.dbo.Cantariri LIMIT 10

1 Like

I have this problem. it has a limit of 200. But I have a table with 3 columns and 3 rows, only 3 rows of records.
I’ve written in different ways and it always gives the LIMIT 200… no other type of error.

select * from mgv.tb_produtos;
select 10 from mgv.tb_produtos;

Database mysql 8.
connect OK, but no return data;

Bubble enforces that you put a LIMIT clause at the end of your select statements to ensure you aren’t submitting huge queries that could return thousands of rows. Currently the maximum setting for the limit is 200. So:

select * from mgv.tb_produtos limit 200;

This will return your 3 rows and as the database grows, up to 200 rows.

it still doesn’t work.
No matter what I do I always get this error, this is a very simple sample query:

SELECT * FROM db limit 200;

I even tried uppercase:


same error, there is no way for me to make this plugin work.

Also, this plugin doesn’t work with MS SQL either, even if there is an option to setup an MS SQL connection. It looks for a LIMIT but MS SQL doesn’t have LIMIT, it uses TOP, therefore no queries work.

You’re typing “select * from db limit 200”. But you don’t select from a database, you select from a table. Might help if you past an image of the API connection code and show the error you are getting.

You simply start your MS SQL statement with select top 200 … I have over 100 queries in MS SQL and they definitely work!

Forget this plugin. I have tried so many times with different MS SQL servers, it simply doesn’t work.
Use APIs instead.

1 Like

sorry, I took for granted the fact I was quering the table and not the DB.
The same queries perfectly work on server’s console, it’s just this Bubble plugin that don’t like them. No matter what I write as a query I always get the 200 record error.

I finally made it, you need to use TOP and not LIMIT. You need to use TOP without parenteses, otherwise you get that error. Thank you.
The problem now is, how do you get the > 200 records if you can’t use OFFSET / FETCH?

There are lots of answers in the forum to that one. Just search something like Limit 200.