Need Help: Import errors, all of the sudden

Hi all,

All of the sudden a plugin that has been working for the past 6 months without issues started throwing import errors yesterday. Below is how I’ve setup the imports (note they are in the “Shared” tab > “HTML Header”.


the error is clear: some module script is loaded before the importmap. inspect the page and see what it is. it can be another plugin or a browser extension.

Hi dorilama,

Thanks for the input. This is a possibility, although, I don’t think this is due to me changing the plugin as this error occurs on the live version of the application containing an outdated version of the plugin. I’ve also tried the application on another browser on my computer and on another computer through Browserstack with the same error occuring.

I suspect something on Bubble’s end (maybe related to the brownout that is supposed to happen tomorrow?). Did they deprecate importing modules this way? Again, this has been working fine for the last 6 months and just yesterday it started showing this error.

I’ve even tried restoring to an earlier save point from 3 months ago showing the same error.

bubble does not own any browser so they can’t deprecate browser apis

open the dev tools and you can see what it is. use a browser without extensions

if you open a random bubble app you can see that bubble adds a script of type module now. that’s probably before your importmap amd causes the error.
import maps are nice but when you don’t own the page can have problems.
you can always load your modules directly: import stuff from "https://yoururl"