Need to retrospectively change a data type


The contact field in my DB is of type number, and I just realised – a hundred user-generated inputs later – that it should have been text. How can I go back and change the field type from number to text?
I have tried using both an API ad bulk edit function with the data, but no success yet. Any help would be appreciated.


Hi there, @felix.njenga… you can’t change a field’s type after the field has been created. So, you will need to create a new field with a field type of text, and then you can work on getting the data from the existing field into the new field.


In what way has it been uncessful?

It should be pretty simple.

Just add the new field of type text.

Create a simple backend workflow that has a single Parameter of type User (assuming it’s your User database in question here).

Have just a single action in the workflow to set the value of the new Text field to the value of the existing number field (or whatever value it actually needs to be).

Run that as a bulk action on your User database, from the app data tab.

Delete the now-unneeded Number field.

Thanks for the response.

Here is the screenshot of where my inexperience is preventig me from completing the workflow.
Screenshot 2023-09-09 at 17.00.17
Contact 2 is the text field. user is the API single parameter.

What am I missing?

Screenshot 2023-09-09 at 16.45.19

I also tried this.

You’re missing a valid value (hence the red error)

The value for Contact Number 2 must be a text value.

Also, you’re using ‘Make Changes to a list of things’, instead of ‘Make Changes to a thing’…

Which, i guess is another way to do this, but it’s not what I was talking about in my previous post.

But if that’s what you’re doing instead, then there’s no reason it shouldn’t work.

So what do you mean when you say you tried it?

If it didn’t work, check your server logs to see why (if you’re doing it that way, privacy rules could be an issue).


Thanks for the input. The ‘change to a list of things’ seemed the most intuitive next step after I could not make the initial effort you suggested work.

I was unsure of how to follow the advice you had shared. To achieve this, would I use the ‘set a slug’ option, with user as the parameter?
Screenshot 2023-09-09 at 19.57.13


Here is a screenshot of what my API looks like:
Screenshot 2023-09-09 at 19.57.13

When I try run the Bulk action, this API does not appear in the drop down list.

When I try set the single item (user parameter) from

I’ve got no idea what you’re doing with the set slug action, or what that has to do with anything?..

In any case, if you’re using Make Changes to a list of things, you don’t want to do that as a bulk action…

Just run it as a regular workflow (either backend or client side).