New Bubble changes to 'Schedule API workflow on a list' broke something in my app

Hi guys,

Recently bubble pushed an update to the Schedule API workflow on a list that interfered and temporarily broke my app.

Previously, I had interval (seconds) empty, and this allowed the workflow being scheduled to properly and quickly execute. The workflow being scheduled involves an external API POST request, which may or may not have something to do with it.

To fix it, I set interval to 2, and now the workflows being scheduled properly make the API call and return data to the app.

I had some users complaining that a feature this was tied to stopped working, and I spent quite a while trying to diagnose the issue and why it seemingly randomly stopped working, as I had never considered a Bubble update itself would be the culprit. I’m wondering what they changed that messed with how quickly this is executed if left empty?

With this foundation in place, we’ve updated the default (empty state) interval for Schedule API Workflow on a List to schedule workflows at a much higher frequency.


  • Empty interval: the default empty state (not zero, but empty) interval for Schedule API Workflow on a list will schedule the workflows with a slight gap in order to balance the need to complete jobs as quickly as possible with allowing other workflows in your app to run simultaneously. The entire batch does not need to finish before other scheduled API workflows can run, but for large lists it may take some time to finish.
  • 0 seconds: setting the interval to 0 is technically possible, but it has the drawback of blocking other scheduled workflows until the entire batch is completed. To avoid this bottleneck and allow for smoother processing of scheduled tasks, it’s often more effective to leave the interval at its default setting. This approach helps in managing the execution flow more efficiently, ensuring that all scheduled workflows are processed without significant delay.
  • Third-party rate limits: please note that while an interval is no longer needed to protect the performance of your Bubble app, there are some cases where it may be useful. For example, if your workflows are interacting with external APIs with restrictive rate limits, you may use the scheduling interval to slow down execution and avoid HTTP 429 Error responses.

So maybe “much higher frequency” is the thing that influenced your API WFs before you’ve fixed the interval?


This topic was automatically closed after 14 days. New replies are no longer allowed.