Forum Academy Marketplace Showcase Pricing Features

[New Feature] Multiselect dropdown & tags

I’m not sure the plugin is compatible with mobile, you can check at https://select2.github.io/

I think that’s the native behavior of the plugin (def not something on our end).

Aha. Yeah might be. Followup comment then I guess would be if it’s good UX or not but I’m not going to get into that, especially if it’s the native behaviour and not something you guys wouldn’t/couldn’t update.

I thought it was built by bubble team.

Thanks for looking into it.

Maybe write to the plugin community, as you said, isn’t working properly under Chrome.
https://select2.github.io/community.html


I asked on Freenode but no reply. You read my mind @JohnM :slight_smile:

EDIT: There’s an open issue for it on Github (amongst 527 others :S)

1 Like

I have another question on this, is there a way to have “initial content” similar to other field inputs?

Use case: for updating a user tags on their profile.

Thanks guys!
Paul

UPDATE: got it using default value option.

1 Like

Thanks so much for this, I will have a play around and let you know how I get on!

1 Like

You could also enable auto-binding to automatically update the list.

Update: bug report sent. multiselect no showing dropdown menu inside popup.


Debug: https://bubble.io/page?type=page&name=multiselect_bug&id=public-sharing-apps-nocritital-info&tab=tabs-1

Live: https://public-sharing-apps-nocritital-info.bubbleapps.io/version-test/multiselect_bug?debug_mode=true

i have the same issue

Just realised that I cannot save the tags using this new element. How do we go about that?

Anyone tried it on an iOS app?
Apparently it’s not working on mobile for the moment? So it might certainly be the same on iOS?

FYI I got this set up thanks to your help!

So I got as far as merging searches but was stuck with the fact that it meant users needed to add all X number of tags in order for the search to work. If there were blanks it would return all.

But as you said- conditionals fixed that, albeit quite long winded to set up- once it’s done it’s done.

Only limitation0 like you said is that it’s really only doable for a limited number but works for me for now :slight_smile:
Thanks!

1 Like

Hi,

I have the same issue in multiple pages.

If I use a pop up where I want to visualize the details of the Item I clicked, the previous inserted data in the mulltiselect dropdown is empty.
If I close the popup and reopen again (without doing anything) then the data finally appear.

If I want to see the details opening a new page (and sending the item to the next page) then the box is always empty.
Also trying binding, but still doesn’t work.

Any advise?

Thanks,

Sergio

when I type in new tags in the multiselect dropdwown if I exceed the size of the input box it just ends up deleting all the tags I just typed in even when its less than the maximum item numbers (Which is 13)

everything is fine until it gets to the end of the input

I get to tag11 and press space

and it ends up deleting every tag I typed in

1 Like

I am also having the problem of a popup used to edit a List of Texts field is not showing the existing values - and any attempt to edit the field deletes existing values.

The use case is a screen for users of my app to set up ‘user defined’ fields, one option being a dropdown and they then enter the options into the Multidropdown which is on a popup (from another popup incidentally):

In the screenshot, you can see that the MultiDropdown is empty - yet the text below, connected to the same database field is showing the current values. Any attempt to edit and the text field immediately shows these values dissappear.

Note that the choices are static but there are no default options - they are all user entered.

I can live with this for a while (during the development phase for my app which will probably be a few months) - and I realise the alternative of creating a subtable to contain these optional values would probably be better anyway (but harder work).

Would it also be possible to allow for values with spaces to be added to these controls - at the moment, the key is created as soon as you press space?

1 Like

We’ve recently pushed a fix there, can you check again?

Hi @emmanuel - the problem is still there I’m afraid.

Thanks for looking at it though!

Julian

1 Like

Is there anyway to disable the [space] from acting as an enter. ie. So users can type multiple word tags?

2 Likes

You can hold down the Option (alt) key to enter multiple words. I just let the user know that they can do this. But it would be nice to be able to disable it also.

1 Like