Forum Academy Marketplace Showcase Pricing Features

New Plugin- Fuzzy search and autocorrect, custom search boxes

@ZeroqodeSupport Is there any way to search only for complete words?

For example, if someone types “PR” I want it to only return people who wrote “I work in PR” not something like “PRESENTATION”.

Also, I tried turning on Case sensitivity and it completely ignored the setting. Does the threshold affect case sensitivity as well?

Hi @giosegar, thanks for reaching out.

Unfortunatly not, our FuzzySearch Plugin is developed to search for not-perfect matches accounting for typos and close matches.
The threshold parameter adjusts your searches. A threshold of 0.0 requires a perfect match (of both letters and location), a threshold of 1.0 would match anything.

I hope the above is useful to you.
Best regards,
Zeroqode Support Team

@ZeroqodeSupport So I can’t restrict the search to be case sensitive if I have a threshold higher than 0?

Hi @giosegar, thanks for your reply.

Unfortunately not, the Fuzzy Search plugin is working differently, it gives you right away approximate results that match your search input.
For this, it is working really well.

For your use case, you can try to use a different plugin or the Bubble integrated search box.

If you find any kind of solution for your case, please share it here on the forum.

Thanks, have a great day!
Best regards,
Zeroqode Support Team

Fuzzy search is amazing, thanks for building this!

I do have a quick question in regards to the capability of this plugin. Can it handle lots of data? Or is this plugin more suited for data types that do not have a lot of data?

Thanks! :slight_smile:

Isn’t this plugin deprecated? I was using it earlier and started facing some problems of page getting hung on the pages that were having this plugin.

Then I had to remove it from those pages as I saw that plugin page says that the plugin has been deprecated and won’t be supported.

If it is still being supported, then I would be keen to have my issue reported and looked into if possible.

Hi @oliviercoolen, thank you for your appreciation.

Regarding your question, there is no specific size of the database that this plugin cannot handle.
The only thing that different users experience with the FuzzySearch plugin, is when the database contains a few thousand items, in this case, it might require a couple of seconds to give you the searched result.

As a hint for speeding up the search in a big database, we recommend using a custom state or use filtering through your database to show different items for the different use cases.

If you like our plugin so far, could you please rate it by going to the Plugins tab in Bubble editor? You can find the plugin by name and give it as many stars as it deserves.
The more feedback we get, the more motivated we are to build great plugins!


Hi @mghatiya, thanks for your question.

The FuzzySearch Plugin is perfectly working, please be sure you have the latest version of it and read carefully its documentation on how to set it up.

If your issue will still persist, please send us as many details as possible regarding your application.
Namely, record a video of your app where the error appears, please send screenshots of workflows, data types you are using, and the settings for the plugin, the repeating group, and the input element.

Looking to hearing from you soon.
Best regards,
Zeroqode Support Team.

1 Like

Hello @oliviercoolen ,

If you are looking for a Search that can handle thousands of DataBase Records take a look at the Plugin Quick Find Search (here is the Plugin page ). It’s pretty powerful for client-side searching on data types with lots of entries.

Another Bubbler had a similar request to search data types with lots of entries here is an example of the Plugin with a DataBase of 10k and 58k entries.


Hi @mghatiya,

In case you’re still having problems with this Plugin, I would suggest you take a look at the Quick Find Search Plugin which is regularly optimized and well maintained :slight_smile:.

Hope this helps and feel free to reach out to me if you have any questions :slight_smile:
Fabrice

1 Like

Lifesaver. I just spent 2 hours smashing my head against a wall with this.

2 Likes

I can’t get my Fuzzy Searches to work on my reusable elements. I have a multi-page app. No page has more than one fuzzy search on them. It was working fine originally then it stopped working a couple of days ago.

Hello, @mack2580
Thanks for reaching out.

In order to investigate this issue, can you please provide us the next information:

  • Prerequisites and steps before the issue has appeared;
  • Screenshots of the current settings for the RG, plugin element, and input.

By the way, this plugin performs appropriately in the Reusable elements, however, you need to check the settings and visibility of the elements carefully.

We are looking to hearing from you soon.
Best regards,
Zeroqode Support Team

Does the plugin have a limit of lines to fetch results?

I ask because my customer database has 6000 rows and the search does not work.

For tables with 150 rows it works perfectly.

Hello @espin.mais

Thank you for reaching out.

The ZQ Fuzzy Search & Autocomplete plugin works with a big volume of information, but it might be limited to the capacity of the Bubble itself. Processing more than 6000 entries is quite an extensive amount and is difficult for Bubble to process.

Therefore, we would recommend using third-party storage if there is a large amount of data involved, something like AWS and other popular data storage options can be used to store data, which can be later retrieved to the Bubble. Additionally, the issue might be in the server capacity, and this might be improved by upgrading the Bubble plan.

In case you have any other questions, simply let us know.

Regards,
Zeroqode Support Team

1 Like

@ZeroqodeSupport does this plugin work in the new responsive engine?

Hello, @equibodyapp
Thanks for the question.

Yes, our plugin is working with the new responsive engine. We have tested it previously (and other users too) and the plugin is working properly.

In case we can help you with anything else - let us know.

Best regards,
Zeroqode Support Team

I love it… I spend 3 hour until read your help… that save my day!!!

To reset the S&A input I created an x-icon resetting the input and the group together and worked. Also works deleting using the keyboard.

But Unfortunately when we keep selecting the whole value and tipping directly over it doesn’t work. Tip is: Don’t select the content just delete it with this wf or with the keyboard.

Yeah for now we will use the keyboard and the x-icon to delete as well. Nothing is perfect guys😅

1 Like

Actually i realized now the problem is with the MOUSE :rat: :sweat_smile:and not about selecting the whole content and deleting it.

Because if you select all with Shift+⬅️(keyboard) and delete it will keep working but…. if you use the mouse to do exactly the same thing it just becomes disabled the input😅. Really weird😯.

Conclusion is: The plugin is a cat 🐈‍⬛. Don’t use the :mouse2: together :sweat_smile::+1:they are “enemies”.

Serious guys if you just use the :rat: to ONLY​:point_up: click in the searchbox (without deleting anything) the “cat 🐈‍⬛ searchbox” deactivate. Yeah they are enemies really :worried:

Hello @speedycleaningcompan,
Thank you for reaching out. :slightly_smiling_face:

We’ve tested the plugin on our side but unfortunately, we did not encounter any alike issues when using a mouse. Therefore, would it be convenient for you to share more details about it? Particularly we would like to see the video recordings of this issue and your setup. For the screencast recording, we can suggest using the Loom tool.

Looking forward to your reply. :pray:t2:

Best regards,
Zeroqode Support Team