[New Plugin] LongPressMe (long press on mobile)

Finally a long press that works

I finally released a plugin that enables long press on mobile.
It also disables any selection, like text, when long pressing.

You can test the plugin clicking on the demo

Free_Iphone_14_Pro_Mockup_5

Let me know what you think
ZDS

2 Likes

Struggling to get this to work correctly in a RG to create a long press conditional on rg cells

Longpress sets state of current cell index however it doesn’t work properly on any cell other than index 1.

Heyhey @dtm2023
You can solve this problem adding not only the ID Attribute name you choose (in my example the word “longpress”), but also the “Current cell’ index” Dynamic Data.

Screenshot 2024-01-08 at 14.29.42

Like that, you can Duplicate as many LongPressMe elements as you need, give for each, as ID Attribute Element, the word longpress + index nr. and then create a Worklow for any of them.

Screenshot 2024-01-08 at 14.32.03

Does this solve your issue?

1 Like

Yes. Thank you!

The longpressme element was inside the repeating group so it was creating a conflict.
Setting the ID attribute to include the cell index removed the conflict.

Thanks for the tip.

1 Like

Amazing!
Thanks for posting, I hope it will also be of help for other people in the future.

Any tips on how to get around this problem?

I am using long press as a selection tool.
When I long press on a cell it adds it to a list (only when list doesn’t contain)
I have a separate workflow that removes from list when long pressed (only when list contains item)

It seems there is not enough of a “reset” so both workflows run back to back even though I have only performed one long press. Long press doesn’t seem to detect when group is released so it records another long press unless my timing is perfect.

Normally this can be fixed adding the object inside a Group and then use the Reset Group. Have you already tried it?

Haven’t tried resetting – ultimately went a different route:

I changed the UX on my approach so that I do not need to longpress again on the item to remove it. Instead, longpressme initiates “selection mode” - once selection mode is on - a single click adds or removes selected items.

Thanks for your tips – the plugin works great so far.

:gift: Giveaway Alert!

In a bid to encourage reviews for the plugin, I’m offering my other plugin, “Swipe left/right/up/down Me,” which facilitates various swipe actions on mobile devices, completely free!

If you’ve bought or are planning to buy this plugin, simply leave a comment on the plugin page, send me a message with proof of your purchase (a subscription won’t do), along with your comment, and I’ll grant you access to the other plugin at no cost.

This giveaway is up for grabs until the 8th of May.

Don’t miss out! :star2:

Hi ZDS,
I just bought your plugin (and leave a comment :wink: ). I’ve an issue with the set up.


I have this message in the debugger and I don’t know where it comes from.

Thanks a lot :slight_smile:

Hey Gaetan,
Thank you for your review! Please DM me with the name of your application, so I can authorise it for the free Swipe plugin.

Regarding your, issue, I don’t know where is coming from. Can you maybe check if there is any empty workflow? Or maybe you have a empty LongPressMe element?

@ZDS Hello, great plugin. I am seeming to get this error and it is causing issues in my app. Do you know what may be causing this?

Hi @dbom009
Are you able to replicate this issue in a page I can access? So I can check where it could be coming from

This looks to be happening to the other user above as well @ZDS.
I opened a fresh page and just placed the element in a repeating group and it produces an error.

I understand the issue now. If you place the LongPressMe A inside the repeating group, then this happens. I think because bubble has issue on finding the element.
You can place it outside the repeating group instead.

Check here how I 've used the plugin with a repeating group: Longpressme-preview | Bubble Editor

Hmm I see. I have used other plugins that work inside repeating groups and have not had this issue before.

I’ll see if I can do something on the code.
Will probably take some time to resolve.

Ok, thank you. I would love to keep using it. But I took it out of the RG and its still making this error happen when pressed.