Forum Academy Marketplace Showcase Pricing Features

Notification accept buttons won’t work

I have something where you can accept or ignore a friend request kind of like Instagram, but I can’t get it to work. I have a green checkmark and a red x. When the green checkmark is clicked it should add eachother to each other’s lists but it doesn’t do that nor does it delete the notification. I’ve been working on this for a bit now with no headway. I already posted this a bit ago and didn’t get a response so I’m posting it here again. Any help is appreciated!

Hey @wknepp :wave:

That’s frustrating. :disappointed: I hope we can help out.

My first guess without seeing anything is to check privacy rules. Have you looked at that yet?

Maybe show your workflow so we can take a look. Or share view access to your app.

I also recommend running the step-by-step debugger to see what is being passed along.

It’s a little complicated because it’s accounting for 2 types of requests. It can either be a instructor request (which is functionally pretty much the same as a friend request) or a lesson request. The button needs to work for either type. I’m not sure if that’s what’s messing it up or not.

Here is the workflow:

image

image

image

image

Can you share the app with view only access so we can try running the debugger for you?

Yeah I guess, but I don’t know how to do that. Could you tell me how and I can do it first thing in the morning?

Sure. Here is a screenshot to show you how to make the app view only access so others can help out:

I won’t have time till Monday to try to take a look at the app. Maybe someone else is free this weekend to take a look at it for you though. Just make sure nothing private is in your app. Maybe temporarily remove any private keys or anything like that before you make your app public.

Remember to change it back to private when the issue is resolved. :blush:

Hope that helped!

Thanks! It is set to everyone can view now. I look forward to hearing back from you!

Hey @wknepp

I was going to try to take a look at it, but I realized there isn’t a link. Can you attach the URL from your editor so we can take a look for you? :blush:

So sorry, here’s the link : Conduct | Bubble Editor

Can you give directions on how to make this work? I tried looking at the app, but I don’t have enough time to try to figure out how it is all supposed to work. I don’t even see a login or signup button on the index page. :man_shrugging:

Once I can see how it works, then I would run the debugger and let you know what is going on. I am just stuck without knowing the process to get to that workflow. :blush:

Yeah sure. It’s not complete but if you go to the page index mobile and run it from there you can see that there is a mail thing that when clicked will show all the notifications. I don’t know how you intend to debug but I can create a login for you with some notifications if that helps. Sorry it’s a work in progress and I’m doing the mobile version first.

1 Like

Sure. That might help. Set up a user with some notifications I can see then I can use the debugger and see what is going on. :blush:

Email: [email protected]
Password: password

Make sure to run it from the index mobile page.
Thanks so much for doing this by the way.

1 Like

No problem, that helped a lot.

So the issue is that the Check Mark and the X mark are inside a parent group. The group has no data source. So make sure that data source says Parent Group’s Notification. That should help a bunch.

Let me know if that fixes it. :blush:

Hope that helps! :blush:

@j805 www.NoCodeMinute.com

For All Your No-Code Education Needs:

Thank you so much. I tried for hours to figure that out and it makes so much since. I don’t know what I would have done without you.

2 Likes

No problem @wknepp. Glad it helped. :blush:

1 Like