Passing an input to GET API

Hi,

I’m new to Bubble. I am trying the following GETAPI in the plugin and it works when I pass the hardcoded value but if i try to pass an input, then it is not working. I would assume that my input is not reaching the HTTP GET request.

I m facing the issues in the following GET request

var options = {
‘method’: ‘GET’,
‘url’: ‘https://api.vehicledatabases.com/vin-decode/{vin}’,
‘headers’: {
‘x-AuthKey’: ‘{X-AUTHKEY}’
}

Question : How to pass the VIN input from the Design. If I replace {vin} and add the hardcoded VIN then it is working but i mapped with the text in the design, the value is not passing to the URL

  1. Another URL also behaving the same.
url: 'https://car-api2.p.rapidapi.com/api/vin/1GTG6CEN0L1139305',

How to pass the input value instead of “1GTG6CEN0L1139305” to the URL?

Please provide some inputs how to deal those URLs inputs.

Thanks\

Put [vin] instead of the hardcoded vin. Then uncheck Private

I tried the same, and I did see the response when I used [vin] in the URL, I was able to see the response when I passed the different VIN number and unchecked the private but the response parameters are not visible in the “Design” tab when I use the “insert dynamic data”. Not sure why the response data is not coming in the design tab. Am I missing something?

That little window that popped up on the left, you just click on the white text VIN number and delete it and click “Dynamic data” then pick the Input's value

Thanks. There are 3 designs fields that I m using. One text is for the vin input that is top most and the one in the below is to display the response field such as “make”. My problem is the response values are not displayed in the dynamic data

To pass dynamic VIN values from your Bubble design to your GET requests, capture the VIN input value in a state variable and construct the URL using that value in your plugin code.

Can you please point out any sample video or the page that explains how to construct such a URLs?

I tried different URLs and i could able to see the responses based on the input. I am seeing the problem only the URL with passing input using [ ] braces as when I create the workflow during button press, the input parameter value is not available.

Is there any bug ?

You need to go through the Bubble lessons before diving into this stuff
Lessons | Bubble

No click on the white static text and remove it, then click “Insert dynamic data”

But you have some other static stuff you typed in your text element like “Result(make)=” for some reason, and you have the same API again after it so remove it