Forum Academy Marketplace Showcase Pricing Features

Password Autocomplete

How do you prevent password autocomplete suggestions? I’m trying to allow a user to change their settings and verify with their password–if it can just be autocompleted it nullifies the protection.

If you don’t have the content format on the input set to password that could be your problem. I’ve never seen this before so if that’s not it I don’t know what it is.

It is set to password-- perhaps it’s an issue with lastpass / 1password installed

Are you on iPhone or something different? I’ve been debugging on an iPhone and I haven’t had that problem.

Check out this post, it’s how to change inputs’ attributes:

1 Like

Browsers automatically auto-complete inputs that are of typepassword. I would say that it’s generally not a good idea to alter that behavior. If users are being prompted to autocomplete the field, it’s because they’ve allowed their browser to save their password. By overriding the default browser behavior, you’re essentially overriding a conscious user decision.

Now if you absolutely want to do that, you can disable autocomplete by adding autocomplete=off to the input. Note that some browsers (Firefox for example) will ignore this and do autocomplete anyway.

This topic was automatically closed after 70 days. New replies are no longer allowed.