Forum Academy Marketplace Showcase Pricing Features

PDF External Link NOT download

Hi Community,
I have a question that I believe has a simple answer and I’m not sure of what to do. I have an app where users upload files. Most files are PDFs. They all have AWS appforest urls. The issue is that whenever i use a link to open an external URL or a button workflow to navigate to an external site, and test, my browser (Firefox) automatically downloads the file. I want the browser to open a new tab and display the PDF in the browser’s own built in PDF website viewer.

In both instances, I’ve been adding https: before the url that begins as //s3.amazonaws.com/appforest…etc. To no avail, the PDF in both circumstances automatically downloads.

Does anyone have any hacks or ideas for this?

Many thanks in advance

UPDATE: I noticed that Microsoft EDGE does indeed open a separate tab and displays the PDF in its own web based PDF viewer. Does anyone know how to create a workaround for Firefox?

if your pdf url starts out like ‘//s3.amazonaws.com/appforest’ then you just append ‘https:’ to the beginning before putting it in your browser and it will display instead of download. So it will look like this: https://s3.amazonaws.com/appforest

Hi Will - many thank you’s for taking the time to review and respond. Apologies as i did not mention that i did indeed include https: before the link. Yes, you are right the links do appear as “//s3.amazonaws.com/appforest…”. In both scenarios I’ve been including https: as a constant.

Can I see a workflow?

Here you go:

Use a link element on your page, should be an option in there to open in a new tab

Hi Lee - thanks for your thoughts. I also tried this avenue and get the same result (auto download). I even checked to see if my popup blockers might have been on, which they are turned off.

I wonder if it is just Firefox. I did have this issue when we recently started creating pdf’s with the plugins but for some reason just adding the https: worked for me and I always use Chrome or Safari.