PDF files attached in Send Mail corrupted

Hello,

I have tried pretty much everything before posting this and hope someone can help me.

My app has a workflow that generates a PDF from an HTML page (a letter), upload the file to AWS and send it as an attachment to an email. It was working well until early this week. Essentially the recipients find that the PDF file is corrupted and cannot be opened. I have tried the following so far:

  1. Tried generating the PDF using different plugins
  2. Changed the way the file is named
  3. Made sure the Current User’s permissions allow viewing attached files.
  4. Made sure the workflow waits for file upload to complete

None of this worked and I therefore think it may be a Bubble platform update over the weekend that has broken this.

Anyone experienced this? Thoughts?

Hey there @kenlaji,

Is the file private or something causing this issue?

Hi Johny, I did wonder - but then I had jot changed any of the permissions. It was all working until that time. Puzzled.

Update - It appears that problem happens when a generated PDF file is uploaded to AWS and attempting to use it in subsequent workflows (for instance attach it to an email or send the file in an API call). PDF created with latest version of ZeroQuode plug-in works, but older versions of it and another plug-in I tried fail.

Seems it’s an issue with some of the PDF creation framework and Bubble actions - sending to AWS and using the file subsequently - that breaks things.

This topic was automatically closed after 70 days. New replies are no longer allowed.