Forum Academy Marketplace Showcase Pricing Features

[Plugin update 2023] ChartJS - Charts and Graphs (TechBlocks)

Hi Alex,

I am using line/bar charts mainly. My users including myself all use Chrome

@christo1 strange, I’m using the same chart on Chrome. Can you please PM me a link to an editor where you’re seeing this issue so I can investigate?

Thank you for investigating. Did you want a user-facing page showing this or access to the editor itself? If access to the editor is what you need, do you have an agency email address I could add to my account as collaborator?

Hi @alex4 I’m trying to populate a bar chart via workflows but when ever the list of data I’m passing has an empty value within the list of numbers (Its a grouping by month), I’m getting the following error:

image

The data array I’m passing is:
image

Also, tried passing the data without the “Formated As” so i’ts not treated as a text, but got the same result.

Hopefully this is an easy fix

I had to revert back to a previous version as the print fix version, did not fix the issue and also caused issues on printing other pages without any chart element on them at all. This might become an issue for other users as well. It was tricky to isolate, but once I reverted back to an earlier version, the non-chart page print issues were resolved.

@christo1 I’ll thanks for the extra info PM you with the email you should add as a collaborator

—————

@aestela thanks for reaching back out. If you copy and paste your expression and paste it in a text element, what does it evaluate to in run mode?

Hey @alex4! this is the text element
Screenshot 2023-01-19 at 10.05.51 PM

It doesn’t matter in what position the empty value is, I get the error. Upon dismissing it, it draws the chart but no data labels are shown and the chart freezes.


I have the same problem, I hope you have an “urgent” solution

1 Like

@evandro1 and @aestela PMing you both to get more detail as I’m unable to reproduce this one. Hoping to resolve this one as soon as possible.

@evandro1 I worked with @aestela over the last few days to narrow in on the issue here. I pushed a fix in v4.38.133

Please upgrade and let me know how it works on your end!