Forum Academy Marketplace Showcase Pricing Features

[PLUGIN] - VideoJS Advanced + YouTube, Vimeo, Wistia, HLS, DASH, MUX, Pre-roll Ads (plus more)

Yep you can do that, on the end, add the bubble options “saved to S3” then that URL will be saved to your bubble storage and you’ll get the S3 URL returned to save in your DB

So that convert video action, next step can create a DB record for example of “result of step 1 converted file saved to s3”
The upload recording action is just used when you’ve finished a normal recording without having to do anything else. But because you’re taking that rcording, feeding it to cloud convert and then trying to save the new converted file to S3 it’s different.

Those make sense if I record a video directly using the plugin inside my app.

But for this instance I’m trying to upload a video recorded using the native iphone camera (ie while not in my app). And then allow user to upload the natively recorded video (saved in their pictures album) and have that trigger a conversion action using the plugin. I’m using the plain vanilla File Uploader element to kick everything off. Does your guidance still hold for this too?

FYI when i try using my iphone I get an error saying Nothing has been recorded… and the conversion action steps never run.

Ah I see. So the output of the File Uploader gives you an S3 URL, use this event and you can capture it and feed it straight into the ‘Convert video’ action

1 Like

Hi Paul. Great tool indeed!
I´m wondering if using your plugin i could manage to pre load some other videos in background so when a button click is trigered the proper video plays flowly whitout load interval tha would break the image sequence for a period. Pelase see what is the final content here.

https://vimeo.com/340103094/0b525e26f4

Hi @michel2
I would think that would be possible. You can do a lot of stuff with it so can’t imagine it would be a problem. I’m free to help out as and when anyway so if you run into any problems then just send us a PM.

@pork1977gm ok thanks that was helpful.

On a different topic the video recorder & audio recorder functions do not work now! I upgraded plugin from 1.172 to 1.177 and those functions do not work anymore. I tested every update & this is what I found:
1.172 - audio/video record both work
1.173 - audio/video record both work
1.174 - audio/video record both DO NOT WORK WORK
1.175 - audio/video record both DO NOT WORK WORK
1.176 - audio/video record both DO NOT WORK WORK
1.177 - audio/video record both DO NOT WORK WORK

On your demo page the video record does seem to work but the audio record does not. I can’t see what version of your plugin you are using on demo app so hard to know what those observations mean.

Please let me about why the Audio record & Video record do not seem to work now. these are big problems for me at moment as those features are critical to my app.

Ok, I’ll figure out what’s happened there. Thanks for the details there too.
Are you running on the new responsive engine?

Actually, can you try setting aspect ratio of 4:3 of the recorder.
Don’t leave that field blank.

yes for new responsive engine. And the 4:3 aspect ratio is filled in.

So the problem is, when your page is on the newer responsive engine, this value cannot be set as it interferes with the element’s height, unless you have it a group then it seems to behave itself. If you’re page is using the original engine then things are fine. I suggest you put the recorder into it’s own group then you should be ok.

I’ll take a look at the control over the coming days and fix it.

1 Like

Hey @pork1977gm I am receiving this error on Chrome (Issues with iPad and iPhone, works on MacBook). It happens when I record and complete a video and then load media to the video player. Safari is working just fine.

Hey Paul,
Can a video like this play…

It’s set to public, but it didn’t work on your player.
Thoughts?
Thanks,
Jude

Hi, did you set a mime type in the field when you tried it? Try adding video/mp4 and see if that plays it.

Hey Aram,
I’ve seen this happen in my testing too but haven’t been able to get it working yet. Pretty tied up at the moment but I’ll try and take a look at it over the next week or so.

Hey @pork1977gm ,

Loving the plugin so far, many thanks for creating it.

One isolated issue being reported is that on some videos on Chrome on MacOS the user is getting a message “You’re attempting to run the ‘Set VideoJS controls’ action when the controls are hidden”.

It’s not obvious to me why this would happen on some video and not others as they’re all hosted on Wistia and the player is pulling the IDs dynamically from the DB. It is consistently not working for the same videos and working for the other.

I though it might be the 'Set VideoJS controls a VideoJS player ’ action I had running but removed that and it’s still not working for them. The video player is in a popup if that helps.

I haven’t been able to replicate the issue as yet. Any ideas?

Thanks

Thanks @martin9

I put a check in to say if the controls are not available then it should display that message to which you are seeing. The check I’m doing may cause an issue with other browsers so I’ve just realised so I’ll test it out myself on Chrome on Mac and figure out what’s going on.

Thanks @pork1977gm , Double checked the site and no “set player controls” actions hiding anywhere, also controls are set to yes. Like I say, I can’t replicate it on my Mac with Chrome so maybe the customer has an older version? Will try and get more details from them. Thanks for your speedy response.

Just to add my 2 cents. Recording a video on Chrome iPhone has also been impossible for me too. It seems likely to me the plugin has some issue with Chrome + ios 15 combination. I have tried 4 combinations of codecs/MIME types; in all 4 I also never capture mic levels:

1 video/mp4;codecs=h264
2 video/mp4;codecs=VP8
3 video/webm;codecs=VP8
4 leaving codec field blank

As a short term workaround I use the ZeroQode video record plugin for Chrome iPhone setup. Eventually I hope Paul can solve this issue so I can use 1 plugin instead of 2. I’ll note the error message I receive is slight different…it reads as follows “The media could not be loaded, either because the server or network failed or because the format is not supported.”

I know Paul is aware of this issue & in due time I’m sure he’ll fix it.

2 Likes

Yes, I supplied a MIME Type but no success there… Hope we can get a fix in soon.

Thanks for sharing!