Post to Facebook via Zapier & Bubble API Connector

I’m trying to use Zapier to post to Facebook from Bubble. However, I am running into issues when I try to use dynamic data in the API connector. I can successfully complete the post when I use form-data instead of json. But for some reason, when I try use json it doesn’t send the data, but Bubble also doesn’t report any errors.

Here is the setup that works perfectly:

Here is the setup with JSON that doesn’t trigger anything at all. I tried to add default values in to test it and it doesn’t work. Can you see anything wrong with my script?

Thanks. Any help would be appreciated.

Hi @seth1,

I can’t be sure looking at the screenshots, but it looks like the quotes used in the Body JSON are “curly quotes,” which often present problems. Select those and replace with a standard keyboard double quotes.

Try using this:


Looking to improve your Bubble™ skills?

Let me turn
:thinking: :tired_face: :confounded:

:grinning: :sunglasses: :woman_student:

Coaching and Development at or schedule a free intro session :gift:

Ken Truesdale

Thanks for the advice @mebeingken. Unfortunately, that did not fix the issue. The strange thing is it’s not getting to Zapier at all, not even with an error or anything. Whereas when I do form-input it goes right through.

Interesting…I did some quick tests to a zapier webhook both with form-data and json, and both worked fine. When I tested with curly quotes, Bubble behaved like everything was fine, but zapier does not record the event in history.

Obviously confirm the url is correct, and maybe the call is corrupt – delete and try again.

I deleted everything and rebuilt it the exact same and that actually worked! :smile: Thanks so much @mebeingken

1 Like