Forum Academy Marketplace Showcase Pricing Features

Problem with ZQ Fuzzy Search and autocomplete

Hello. I am using the above plugin. I have a search field on the page and a group that has a repeating group. My issue is when I search for a file name, no results are shown. The plugin and the repeating group are in the same group.

Any help is appreciated!

Hello, @grace.hallak. Thanks for reaching out.

Please make sure that the Data Source of the Search&Autocorrecr A and the RG Attached Files elements are the same. Also, you can try to set as Data Source the whole table (Posts), instead of the specific column name.

Hope it helps :pray:
But if it doesn’t, please attach the screenshots/video record of all element properties (Search&Autocorrecr A, RG Attached Files, and Input Search Field) to let me check if you have set everything correctly.

Regards,
Zeroqode Team

1 Like

I copied everything the same from the demo.

@grace.hallak,

Thank you for your screenshots. Could you please add our [email protected] email as a collaborator of your app? I need to take a look at the setup of your app, it can help to find out the root cause.

(The support email can be added as a collaborator on any subscription plan).

I Will wait to hear from you soon.
Regards,
Zeroqode Team

I added your email. it is in the page “Files”

1 Like

I was targeting the file “test123”. This is what I am getting

Targeting file “test-logo…”

File not related to the search is showing up

I remove one “n” and the right file is showing up now. I think the plugin is seeing 2 common "n"s in the file names

@grace.hallak,

This is normal behavior for the Fuzzy Search. This type of search does not return the exact matches, but the alike ones.

You may also test the search results, depending on the Field to search parameters and find the best search parameter to your needs:

I have added the flies_test page to your app where the search feature is workable. Please check and set your flies’ page the same way.

Hope it helps :pray:
Regards,
Zeroqode Team

is there a way to find the exact result?

does the search box that comes with bubble work well?

@grace.hallak,

Yes, the search box works well.

As I have said, you may test the Field to search parameters to find the most appropriate search result display:


Regards,

thank you

1 Like

Does this work on server side on client side?

I’m concerned about GDPR when searching for customers data.

Hello, @ryanck
Thanks for your question.

Yes, this plugin works on the client side, because it’s only element. In the element all actions in the client side.

Allow me to note that the ZQ Fuzzy Search & Autocomplete plugin uses only information, which is in the database or any of the used API of your application.
You specify the Data Source from which the plugin gets the information, but it does not store it.

You can read more about GDPR policy at Bubble following these links:

Hope it helps.
BR,
Zeroqode Team

1 Like

Hello @ZeroqodeSupport

How do you achieve the when input is focused, show the RG with the values without constraints and then when entering text in the field above, narrow down the results?

Hello,

So, your request directly reflects the functionality of this plugin.
The plugin allows you to search for perfect and close matches from an indicated data source (DataBase of your application).

In case you would be interested to know more about this plugin, we strongly recommend you to test the plugin functionality/design by visiting its Live Demo page and Bubble Editor :

https://zeroqode-demo-16.bubbleapps.io/fuzzy

Hope my answer helps you.
Regards,
Zeroqode Team

1 Like

I’ve tried and tried to get this to work and somehow It just don’t want to work.
I’ve been looking through live demo page to match everything up but when I type anything in my input field everything dissappears in my repeating group.

I assume I’m not doing something right as the plugin seem to work for others.

This is what my repeating group is set to:


This is my input field:

And this is the plugin setup:

I’ve been tearing my hair out for an hour, as no matter what I do it seems not search… Any help will be greatly appreciated…

Hello, @kim3
Thanks for using our plugin.

First of all, please check your condition #1 in the Repeating group, because the Toggle element was a bit changed by the Bubble platform: Bug with group focus - #17 by eve

Also, please check if you indicated the same Input ID in Element of Plugin and your Repeating Group ( we can’t see this information on your screenshots);

Additionally to all mentioned above, please provide us the screenshots of the Conditions for the Input field. On our Demo Page, there are not any conditions, so they may have an impact on results.

Please provide us the required information and we will investigate your case.
Regards,
Zeroqode Support Team

Thank you for getting back to me
It seems my toggle work, but not sure how to check if toggle interfere with search?
The ID attribute in my repeating group is same as in input and ID element.
See below:


Also see below my conditionals on my input: