RE (responsive engine) element full width

Hi Bubblers,

Quick question for those familiar with the new RE (responsive engine) and having a Group element (header) stretching the length of the page (currently its not behaving like I intend, which is to stretch across the screen, I must be missing something).

My setup:
Profile page: Layout, has a container layout of Row and is set to Full width (this would be the parent).

Header Group Element (really just a group): Container layout set to Row, Min width is set to 100%, Max width is set to inf (infinity Im assuming).

When in the editor it looks fine but when I Preview the page the Header Group element doesn’t stretch all the way across.
Here is an image the page is purplish to distinguish the difference between the two and the setting I have.

1 Like

I think it’s a bug. Having the same issue.

Hi @Zaque,
Is your issue stretching an element across the page or with the repeating group not displaying? or both?

@luminrabbit - Stretching issues with new responsive engine

It’s definitely not a bug and is solved. I made a copy of a page and duplicating the page to the new RE (responsive engine) it automatically created a parent group element/container and this was set to “Make this element fixed-width” which was causing the issue once un-checked it worked fine.

I was sure I checked all of the parents but definitely missed this one :slight_smile:

1 Like

Hi guys, I’m facing a similar issue.

I’m trying to create a responsive design for my app. It’s primarily mobile but depending on the phone size it should adjust the design to be seamless.

I tried to use the new responsive engine but even though i set the width to “inf” on all elements, there is still a small white space that stretches through the whole page on the side of the phone. I coloured the background of the page grey to make the problem more visable.

In the editor this white space doesn’t appear but in the preview it does when opened with a phone.

Would highly appreciate your input!

Here is the preview:
Here is the editor: Kork-passions | Bubble Editor

Thanks, Daniel.


I don’t see any white space… where exactly are you seeing it?

Hey Adam, thank you so much for your response!

Try to open the link with your phone. This is what I get:

Strange, I’m not seeing that on my phone, nor on any responsive device emulation in a browser…

Very strange, i’ve checked on several devices and the issue only appears on mine (IPhone X). Thanks you Adam anyway, really kind of you.

If you have any issues, maybe I can help.

1 Like