Record is created correctly but fields show as "Empty" in the debugger

I have a Workflow step that Charges the User. When Payment’s successful, I create a new record for my tblOrders. That works fine and everything is recorded.

Thing is, despite recording the order data in my tblOrders, subsequent workflows don’t work. When I run the debugger in “Step-By-Step” mode, the “Create New Order” step has mostly empty fields. Thing is, when I run the Debugger the Order record is recorded AFTER the user has been charged (a process that takes me away from that screen to get to Stripe and then takes me back).

This shows the Debugger that tells me that everything is empty on the Create Order Step


This shows fields that are populated despite being shown as empty in the debugger and several steps AFTER having been navigated away to Stripe and back.

I’d love to understand this because I want to send SMS messages etc that contain information from the Order to confirm it to the User but, I’m guessing, because the Create Order step shows empty data, it isn’t available to the SMS Step. I guess I could create Custom States or something that are populated from searching of the recently created Order to then generate the data needed for the SMS but that seems like a lot of extra steps.

Can anyone guide me through this?

Not exactly sure what’s causing it since we don’t know how your WF is structured. Would you mind showing screenshots of it?

Off the top of m head, I’m guessing it’s either a privacy rule issue or you weren’t able to correctly reference the parameters