Repeating Group Collapse

Hi - I have an RG with multiple groups with each. ALL items within each group are set to collapse when hidden. I have certain parameters to hide groups (within the RG), based upon certain parameters.

For some reason, those repeating groups cells will not fully collapse (even though there is nothing visible within those RG cells)… See this for what i mean:

Thoughts of what is going on here?

The entire cell of the repeating group needs to be a group of its own and set to be collapsible because a repeating group cell by itself cannot collapse. Then everything needs to go within that group and it should solve your issue.

Got it… So to clarify, you are saying I should have the following heirarchy:

  • Main RG
    • Group (That hold all content of Entire cell of RG)
      • All other items

I just tried this and i’m still getting the same issue

Exactly. In the Repeating group cell you want to have one group that takes up all the space that could possibly be there as if everything was visible. Make this group collapsible. Then inside that group, every other group that has conditional visibility also needs to be collapsible. And it is important to continue that trend all the way down to every nested group. There can also be no space between groups. If you have 10px between two groups and they both collapse then the RG cell will be 10px high. If you need things like that then just create a 10px group and make it collapsible and have the same visible conditionals as the surrounding groups.

Ok cool! Let me test and report back in a couple minutes

1 Like

Ok so I tried everything, still didnt work!!! Any ideas?

I can confirm that it is definitely still the repeating group elements… In the debugger, it just shows empty space and has the lsit of the other items… see the pic

Ok I figured it out!

On the main RG, I had “stretch rows to fill vertical space” ticked. Because my main group above that in teh heirarchy is a fixed height, it was stretching all RG items out vertically!

Screen Shot 2022-07-26 at 4.25.30 PM

I unchecked that box - seems to work now