Reply to field not working in default "send email"?

I’m trying to send email from a specific no-reply email using the default “send email” action.
I clicked on specify a different return-to address, and entered the email I want to send as, but the de-facto email that I get as the sender (the way I see it in my gmail) is [email protected]

What do I miss?

Hi there @silverishclover,

Make sure to setup a custom domain in your app settings

This topic was automatically closed after 70 days. New replies are no longer allowed.