Specify a different reply-to address

is the option to specify a different reply-to address working?

I had to set the sender field and add the e-mail there using the syntax

Name <e-mail>

since else the user with reply was replying back to a no-reply e-mail address at bubble.is

or is it Window 10’s Mail app that is ignoring the reply-to field in e-mails?

see screenshot:

It should be. Can you reproduce the issue without the sender name setting in the forum app so that we can all test?

Here it is:

btw, it is not clear what the “Sender” field should be when the “Use different reply to address” is checked. Is it the name in the From or the name shown when one presses Reply? I believe it is the name shown in the From (independent of the ReplyTo being set or not). However I wonder why is the checkbox needed at all. If the ReplyTo field is empty, it should imply that we don’t use reply-to feature

Anyway, the ReplyTo seems to be ignored, but I don’t know if it is the Win10 Mail app that ignores it or Bubble forgets or doesn’t set it correctly in the original e-mail

What I’ve found to work for me is to use a sender specifying name and e-mail in the same field using say someone <someone@somewhere.com> syntax

btw, this text editor doesn’t allow me to type < and > directly (treats them as HTML)

I think it’s a Win10 issue, just tired on MacOS + Chrome + Gmail and it works fine for me.

I suppose you mean you tried both buttons in that sample (first one is the method I use now, since I don’t really need something else to show at From than the one that will show at To when doing reply).

Btw, see my other comments above

  1. why is the checkbox for reply to needed at all? An empty reply-to field should be enough to not do reply-to
  2. due to having the checkbox, the Sender field can be confused when it is checked on whether it means it is the text name for the reply-to (user may think the reply-to address is an e-mail only, not name and email syntax)
  3. not all non-programmer users know the format name <email>. Many may be just giving there a plain e-mail since they won’t know how to give the name. Probably having separate fields would be better, but guess that would break existing code. Unless you keep the underlying data model as is and just make the UI better there to show the name and e-mail in two editboxes side-by-side (split and merge the e-mail address that is yourself in the property editor UI to show as two separate text fields instead of a single one)

Hi Emmanuel, I think I may have found a bug (as I was figuring out the reply-to feature, I found this thread). I found that I had to add a dash (“-”) between “Name” and the < email > in the Sender Field.

So, for example, if I specify Sender as 669 Blue Jay < 669bluejay@gmail.com> , the sender name gets cut off in Gmail and shows up as “669 Blue Ja”:

But if I specify Sender as 669 Blue Jay - <669bluejay@gmail.com>, the sender name displays correctly as “669 Blue Jay”.

I added the dash on a hunch, fortunately it works. Is this some G-mail formatting issue? I haven’t checked other mail apps. I am using chrome on macOS Catalina Version 10.15.6.

Preview here: https://b2b-email-for-forum.bubbleapps.io/version-test?debug_mode=true

The editor can be edited here: B2b-email-for-forum | Bubble Editor