Required field 'resource' not specified : Google Compute Engine API


I’ve connected my Google Compute Engine API to bubble via a JSON Web Token. All the usual stuff like starting or stopping my GCE instance via the API works flawlessly.

What doesn’t seem to work is making a new instance from an instance template via the API.
When I click on initialize call with all my parameters set correctly according to this page, here’s what the API connector returns -

Here’s my API Call settings -

I’ve spent the last few days scouring Google for anyone else who might’ve had this problem, and all I found is a person who had the same error, but he’d written his API calls in Python and managed to fix it, so that didn’t help me out at all with Bubble.

Moreover, I know the API and parameters are correct because I copy pasted them from Postman where they’re working flawlessly.

If anyone’s had this problem or know anything to help me out, any help would be greatly appreciated!

Thanks a ton!

This sounds vaguely familiar. I have an API doing posts using a json body as well, and I seem to remember having to add the Content-Type to the shared headers.

Just a thought since that isn’t visible in the screenshot…


Thanks a lot! That worked!