Responsive pic in popup?

Hi -

A little confused with responsive design.

I have a popup with a pic inside. When I display on a mobile screen, the pic does not seem to shrink. since the popup does shrink, the pic is displayed pushed to one side.

Any ideas?

Thank you!

Make sure …

“fixed width” is not ticked

“Keep element proportions” is ticked.

And then in the responsive settings …

“Fixed width” is not ticked.

“Keep Element Proportions” is ticked.

You can also collapse the margins when it gets small.

Then it should work.

1 Like

Thanks for the quick response. Your pic looks perfect. I hope to make mine similar.

I’m still getting strange results here, even when I copy your settings (shown below).

Weird aspects

  1. My left margin unexpectedly increases from the tiny 5px margin I started from
    1.1 I tried placing off-center to deal with this issue. Works at one size, but not all.
  2. Can’t keep centered

Dumb ideas from here

  1. Another setting?
  2. Different behavior for my dynamic data?
  3. Interference with another control?

Image settings

Responsive settings

Responsive explanation

Iphone view (picture blacked out)

Is it the “fixed margin” in the resposnive settings being on the left ?

I don’t think so. I tried it both ways, with the same results.

Are you loading dynamic data? Or a single photo?

Clutching at straws here. : )

Popup too small ?

My “responsive explanation” seems like the pop up is smaller than the image. And the margins/sizing are adjusted to handle.

Not sure why.


Does your pic appear ok at full size and on phone?

If anybody follows me, I never found a solution that worked 100%. So, I made this popup window fixed width.

@michael.schoeffler Is the ‘alert hello’ element underneath the image inside the popup? If so, that may be interfering with the responsive settings - I would double-check that they’re not overlapping. You can select ‘position alert at the top’ in the alert property settings so that the alert is outside of the popup. :slight_smile:

1 Like


I didn’t realize, but “alert hello” (an element I inserted when I was debugging) created interference.

Thanks tons (and to Nigel too!) for the assist.

1 Like

Awesome! Yes, that happens to me all the time too - they’re tricky to spot!

No problem at all! :slight_smile:

1 Like