Forum Academy Marketplace Showcase Pricing Features

RG vertical scrolling responsive in height

Hi everyone,
I have an issue and for the first time I did not see any convenient answer on the forum. I need to do a responsive in height RG with a vertical scrolling. But this does not work.
I introduced some HTML in order to have the RG at the height of the screen. But then the RG is no more scrollable.

I need to do that in order to reproduce a messaging service similar to Messegenr for example, having the list of the discussions scrollable.

Is there any solution adaptable to every search engine ?

1 Like

Finally I found an answer, you have to put overflow: scroll in your html Capture d’écran 2020-06-02 à 14.49.33

3 Likes

I think I’m having similar problems - could you add some screenshots of what you’re trying to do? What can I do so this left column fills to the bottom? If I edit the height of my RG, it doesn’t let me scroll to see the rest of the items

Put the RG inside a group, and extend the height of the group.

Also, experiment with the following RG view types: vert scrolling and ext vertical scrolling (with the RG inside the group).

Thanks, I’ll try some options with another group.

ext vertical scrolling makes the height change as you scroll so it scrolls way passed the map on the right.

That’s why you have to put the RG in a group

Hi,

I tried this but nothing happens. I put Discussion and RG as IDs on the elements and just added a HTML on the page with the content you showed here. But the elements doesn’t seem to get the settings from the HTML. (as you can see I’m not a JS expert).

Cheers, Peter

I think you maybe forget to put some ID attribute to the element you want to control :slight_smile:
I needed time to understand that too

Yes, I put in IDs “RG” and “Discussion”. Is that correct?

Could you show me your code and what you did in order for me to understand ?

Yes, thnx:

I am not a coder , but maybe numbers in ID attribute are not accepted. Moreover, for the calc function you must write it with spaces as calc:(100vh - 80px) so spaces between vh and - and 80.
Tell me if it is working after that :slight_smile:

Thanks for spying my detail misstakes. Now have this:
Screenshot 2020-10-08 at 18.25.56

Changed IDs on the elements. Still not working.

There is no space between calc( and 100vh . But maybe would be easier if you send me the link of your app

Sorry, cannot - it’s a clients app. Can one really reference an element using a #tag?

Now I’ve put it in an open app: https://bubble.io/page?type=page&name=height&id=petertest&tab=tabs-1

You have probably solved, but you are doing instead of .

**script instead of **style

1 Like