Saving Date Ranges as a List of Date Ranges

I have work flow where I attempting to save a date range to a field that stores a list of date ranges. In the first workflow action shown below I am saving the date range to the RosterTenureTemp field. In the second I am referencing this field to then add the date range to the RosterTenure field. When I run this, the date range written to RosterTenureTemp but not added to RosterTenure

image

image

Initially I did not have a RosterTenureTemp field and tried to save directly to RosterTenure within the workflow action. This did not work either.

Thoughts? I can’t figure out why this isn’t working. I am wondering if Bubble doesn’t allow a list of date ranges to be saved.

This would be useful to have since it is much easier to group date ranges of tenure rather than trying to infer from the raw data.

Thank you for any assistance!

Hi there, @naveenreddyla… you should be able to save a list of date ranges, and you shouldn’t need the temp field. Have you checked the debugger to see if it can help you understand why the range isn’t saving?

Best…
Mike

Hi Mike,

I appreciate the response. I tried debugging but nothing seems to stand out. You can see from the debugger the that date range seems set to be added to the RosterTenure field. Admittedly I don’t know what “Date Range -1” means.

This is the only field that is giving me issues in this specific table/thing.


image

Thanks,

Naveen

I believe date range - 1 just means it is the first date range in the list. So, you’re saying after you run the workflow, you don’t see the date range in the list when you look at that roster in the backend on the App data tab?

That is correct. See below.

Typically there is a simple explanation for something like this, but I am a bit stumped on this one.

I actually just learned that the date range list doesn’t show in the detailed view of a thing (maybe it’s too difficult for Bubble to show it in that view). If you cancel out of that view, does the list show in the table view?

1 Like

Aha. yes it does!

Thank you for the help! I should have l checked the table view.

1 Like