Scheduling API Workflow on a list that runs a subsequent API Workflow on another list - no working

The first API that I’m running on a list run fine but then the workflow is halted completely when the second API (on a list) is run. Is anyone else experiencing this? It seems to have come out of nowhere and rolling back to previous versions is not solving the issue.

I have been having issues with my workflows not triggering properly in the last 36 hours.
It’s been working fine for the last 1 year…


Are the workflows you’re having difficulty with in similar circumstances?
I created a test workflow running a very basic API on a list of numbers and then sending that list of numbers as the only value so that a second API can also be scheduled to run on the same list. The second API does not run and the workflow halts.

Have you noticed any other patterns?
I’ve not had any trouble like this in several years and our systems rely heavily on these workflows. I can’t even guess what other problems this might cause.

I was just praising Bubble yesterday for having such a good streak of server uptime!

It’s pretty hard to diagnose what the issue is, but I’d probably guess it’s something related to backend workflows and workflows that require a create/update to the database.

I seem to be seeing a fair few empty rows in my database. If my workflow has 10 steps, like 4 or 5 steps of it are triggering correctly, and others not. It’s pretty hard cause I have so many inter-related workflows triggered on one action so I can’t say for sure what steps are working but yes doing something like what you have done might be the best way to narrow the issue down

1 Like


I recently discovered that if a single error (API) is detected, the whole thing stops without warning. I had to add another control mechanism… The good news is that in the Backend Workflows Logs you will find the error.

Hey John, that’s good to keep in mind for future workflow errorss! Thank you
I tried my workflow again today and everything worked fine again so hopefully it’s not something that plagues us in the future.

1 Like

Damn, so it looks like it’s just me that’s still encountering this issue. Still haven’t gotten any message from Bubble even after 24 hours

This topic was automatically closed after 14 days. New replies are no longer allowed.