Forum Academy Marketplace Showcase Pricing Features

Screenshot Plugin

Greetings,
i am currently fiddeling with an external website screenshot render service like https://www.pagelr.com/ or others.
These services are often used for “website summary” tools, improvement lists, even bug reports.
Nice combination of website description and visual impression.
Thought this might be a good idea for a “plugin”.
(instead of generating images externally, copying them into the bubble database and generating some sort of “screenshot up to date” mechanism.)

Cheers
Urban

1 Like

Have you tried adding the plugin yourself? Start with the API connector (and then make it a plugin :)) If you pick type of data as image i think it should just work.

wow that what i call fast support :slight_smile: excellent.

ya tried API connector (and the nice “postman” tool…works fine in the postman tool
(with https://api.pagelr.com and a key i got as a trial user) but i always get an

“API connector error: this header is not correct undefined” or sometimes an
“object object” error (when i click the initialize button) …

i am sure i am doing something stupid :wink:

cheers u.
p.s. type of data was “image”

I love this idea!

Can you share a link to the editor

hi :slight_smile: by “editor” you mean the “buuble wokflow editor”? I am not there yet …the "error messages pops up when i click the “initialize call” button in the api connector. Or do you mean the “postman” editor? (the tool you recommend using
BEFORE APIing (https://www.getpostman.com/) .

see link in screenshot


—8<----
The link i generated for the screenshot was:
https://api.pagelr.com/capture?uri=apple.com&width=280&key=blablabla&maxage=1600000
(replaced the real key with “blabla”)

maybe this looks familiar? Is this a bug?

…if someone could have a look at this in the (public editor) “Screenshot Render PageLR”
i would really appreciate the help …what i can add…“init plugin” takes 15-25 seconds…hm.
(didnt realize that “plugins” could also be copied to the “public editor” Sorry :slight_smile:

I still can’t see a link to the editor on your thread.

sorry was not clear enough. i copied everything to the public app https://bubble.io/page?id=forumapp3
…api connector…
…“Screenshot Render PageLR”
…i removed the “private key” obviously but the “init api” requires with or without key 30+ seconds to respond

…got this "funny one right now…

Thanks for looking into this…

urban

Well you need to enter a key first, cantsaythat i’m sure is not the real key right?

:slight_smile: thats why i wrote above that i tested it with the “postman” tool (w/o) key and it works fine.
e.g. https://api.pagelr.com/capture?uri=apple.com&width=280
what you get is

with a proper key (simple klick on the demo account you get

…but the above error message (object object or "fiber timeout?1 :slight_smile: ) …look like something is wrong WITHIN bubble…or am i completly off page?

thanks for checking…

…almost finished my app…just need the screenshots (and more db speed…but thats another topic)

thanks again for taking the time looking into this

urban

how would i label this as a BUG and move it into the "bug section?

I just moved it to the bug section, but that is to allow others to check if the bug is real. If you have a genuine bug, raise a formal bug report.

thanks…i am pretty sure it is…see the screenshots above…and the test we did…but if it turns out that we were stupid …even better…:slight_smile: …one way or another this "thing2 currently is a show stopper for our entire project…so help needed in one way or another…
thanks

Greetings, still cant figure out what the problem is. Is there a way to figure out if someone is looking into this?
Interestingly i could find that https://storetemplate1.bubbleapps.io/ did a template with what we would need (it looks like some sort of screenshot tool)…BUT Cant test/buy it because…here we got

This “bug” shows up for the last 8 days. After testing the “chat tool” on bubble wits the same bug shows up…
Can someone confirm this?

We are always here to help. See below link for plugin that I created using pagelr.com

Let me know if you need any help.

https://bubble.io/plugin/pagelr-1482914583615x474441435101790200

Enjoy!

1 Like

To submit a bug report, there is a link on the “Community” page in Bubble.

Here is the bug report link:

Awesome, implemented it …tested it (with 250 screenshots) . works.
Thanks a bunch…

Funny: if i try to implement the plugin myself (with the API connector ) i still get the above mentioned error messages. so no clue how you did it, but hey…it works :wink:

p.s. the "delay paramter (in ms) seems to be mixed up. if i set it to 1000ms (wait for 1 second…the plugin waits…eternal…
ms …seconds…mixup…maybe…

I will check it out. I think the delay (especially a long delay time) can cause the API plugin to timeout.

I will let you know after I have made some tests.