SendGrid Co Pilot Plugin Bug

Hello Bubblers,

I’ve been using @copilot CoPilot’s Sendgrid Plugin for a couple of weeks now and everything seemed to be fine - it was sending emails as usual. However, when I tried to change the email that I used in SendGrid, of course, I also changed the email in the plugin’s WF actions, it just stopped sending emails.

I’ve been stuck for a couple of hours already trying to figure out what’s wrong but I really don’t see anything. I’ve checked the

  • API keys
  • Template IDs
  • Logs
  • Debugger

I’ve tried everything that had potential to contain an error on my end. When I check the debugger and logs, it seems to be working fine, no errors whatsoever. It sends the substitution tags correctly, sends the emails fine but It still doesn’t send any emails. At first, I thought it was something on SendGrid’s end but when I checked activity in SendGrid, there was no emails sent so I guess the plugin was not able to forward the email to SendGrid.

In this case, would it be better to then just use the API connecter manually instead on relying on plugins?

Would greatly appreciate any insights. Thanks!

On second thought I remembered AWS removed their support for node 12. I assume this plugin was affected by it?

Hey @ntabs,

Thanks for sharing the issue you’re running into with sending emails through SendGrid. We haven’t received any recent reports of email dispatch issues and we rely on the SendGrid plugin ourselves to send emails so we can’t say what exactly the issue may be. Additionally, Bubble’s automatic update to Node 14 has not been initiated as of yet.

If you haven’t already, you could file a bug report with us and provide more specific information so we’ll be able to investigate further on our end and see what’s going wrong. :slight_smile: