Forum Academy Marketplace Showcase Pricing Features

Separar itens de uma lista dentro de um repeating group

Boa tarde , poderiam me dar uma ajudinha? em meu banco de dados, coloquei um campo que permite anexar vários arquivos. Depois, no meu projeto coloquei um link que trará o link desses arquivos anexados para fazer o download, o link funciona com 1 arquivo, porém quando tem mais de um, da erro. Tentei fazer um repeating group para exibir os links de cada arquivo separadamente, mas notei que ele não separa, ele junta tudo com vírgula, tentei usar o unic elements, converted to list, mas também não deu certo, sabem me dizer, como separo itens de uma lista em um repeating group?

Acho que você poderia criar um repeating group dentro desse repeating group usando o conteúdo desse campo como dados. Assim vc teria uma tabelinha com os links dentro de cada campo do repeating group.

Opa leonardo, tudo joia? fiz o teste aqui, porém ele ainda trás tudo junto, da uma olhada no link ai abaixo. Se você olhar no segundo link é como está aparecendo para mim. separado por vírgula.

https://drive.google.com/file/d/1qg4oZqvmamag7HsjxXlQXDet905GSnQa/view?usp=sharing
https://drive.google.com/file/d/1MpVx3tGhfCz0eJ9sM9DWgA0ANLvwZ3AQ/view?usp=sharing

Seguinte, acho que vc pode estar com alguma config errada em algum ponto.
Eu fiz rapidinho esse exemplo aqui de como eu faria algo assim, diria pra vc dar uma olhada e ver se consegue te ajudar.

Parece que os seus dados estão sendo listados corretamente, mas não estão sendo distribuídos no RG direito.

Que estranho, eu conferi todos os itens que você fez, estão exatamente iguais aos meus, não entendo o porque no seu ele separa os itens com as vírgulas, enquanto no meu ele mantém junto.

Opa Leonardo, só passando pra avisar que consegui, fiquei horas pesquisando aqui pra entender o que estava errado. O erro estava no insert dos dados no banco. Eu estava usando um multifileUploader e ao inserir os dados, estava usando o comando ADD, o bubble então estava juntando os dois anexos e colocando como apenas um, por isto não estava dando certo, troquei o ADD por SetList e agora funcionou perfeitamente, agradeço imensamente pela ajuda e pelo tempo que dedicou.

1 Like

Boa Rodofa!

Qualquer coisa duvida ai só voltar no post que vamos ver o que rola.