Set Slug does not works

Would it be possible that “set slug” feature does not works ?
Im setting up this feature like 100th time and now having an issue with it.
Im creating simple “posts” an then I wan to set them slug from the post title.

The workflow chain:
The “Create a thing”:
“Set the slug”

Page is type “post” and all the groups are set correctly…
In the debugger I even see the slug, but once I go to the app data the slug is empty.
I have no idea what am I doing wrong.
Any tips?

*i tried to search first, but haven’t found such a banal thing :slight_smile:

Hey @jankosara :wave:

I think it has something to do with that you are using the parent post instead of result of step 1. Try setting the slug on result of step 1 to see if that helps. :man_shrugging:t2: Also, the condition might also need to refer to the same thing too. Or just remove the condition completely since it won’t have a slug when it’s a new post.

Privacy policy? I would add that next to my to-investigate list.

Are you trying to set the slug for the Post you’re created in the workflow?..

If so, your second workflow action is wrong (unless you actually are trying to set the slug on a post which is not the one you’ve created in step 1?)…

You should just be setting the slug on the Post you’ve created in step 1 - not the Current page post.

1 Like

Hey @adamhholmes , @rico.trevisan , @J805 thx for answers.
When I was trying to set this up I obviously tried tu use the “result of step1” when setting slug like this:

Also tried the condition to refer to the same:

the result is the same :confused:
No slug is created…

Nope, I have no privacy rules on that data type…

The second one should definitely work…

Although, logically, there’s absolutely no need to use an only when condition here at all (a newly created thing’s slug will always be empty)…

But in any case, if it’s definitely not working the debugger should tell you why, so use that to find the issue…

1 Like

This topic was automatically closed after 70 days. New replies are no longer allowed.