Forum Academy Marketplace Showcase Pricing Features

[SOLVED] : Bubble API Connector : Unable to select Bubble Type

Tried connecting to import.io extractor, I’m unable to select bubble type.

I came across this exact same issue trying to post to Filepicker.io. In the step where I’m initializing, call is asking me to select a type for bubble, but there is no option or dropdown or etc. to do so.

@francisthomas712 Just a suggestion, but I wonder if it might be helpful to make the title of the post “Bubble API Connector: Unable to select Bubble Type” for future posterity. Thanks.

Are you sure you are asking for JSON ?

Have you set the content type in the Header to be JSON.

Bubble only accepts JSON back, and that doesn’t particularly look like JSON.

It can be hard to debug though. What is useful is to use POSTMAN to do the same call and see what comes back.

Done.

This is what the data looks like

@NigelG It’s actually JSON for both of us. The Bubble screen just isn’t formatting it for the browser that way. The issue is that Bubble is asking us to choose a type for its internal validation so that we can in turn use it for workflow actions. Only problem is that there is no visible field to choose. I’m imagining this would be like choosing fields when making db items, only the choice options are not available. If you look in both screenshots the right column under bubble type is empty.

Thanks!

No, you are right. That looks like JSON.

I wonder if it is the arrays that is causing issues ?

Somehow I feel it’s the group that’s causing issue. I’m not an expert, came here for the #nocode.

@NigelG and @francisthomas712 I’ve no arrays or groups from my return - just very simple JSON struct- and experiencing the same error. Making me think the problem isn’t your structure but the API Connector.

I have seen this before with a fairly complex API. You see something on the left but cannot import.

But then … I can get it to work fine on other APIs including ones with repeated data.

Trying to work out why some work and others don’t is hard.

I tried doing this with simpler API’s/JSON’s, do you know where I can get a sample set to test?

I am very interested to see if we can get import.io to work. Currently I extract to csv and upload. This wouldbe really handy.

Learnt a bit about JSON, made a very simple one using myjson.com. Same issue persists.

What API did you use ?

http://myjson.com/pehk

The API is from myjson : https://api.myjson.com/bins/pehk

Yup, seems broken.

This is an older API call.

Copy it over …

Something has gone wrong somewhere.

@emmanuel might be able to help ?

Okay, thanks Nigel. This is actually good news, means that its not a product functionality thats missing, but something that can be fixed :slight_smile:

1 Like

@emmanuel bump?