[SOLVED] Dynamic Dropdown Input Form not populating data from related 'Thing'

Hi there,

I’m a new to bubble and am loving the possibilities!

I’m working on a (what I think should be) a simple task manager that allows for nested ‘tasks’, and nested ‘folders’. I was wanting to associate each task with a folder but unfortunately my folder dropdown isn’t populating as expected. This is what I’m seeing…

These are my ‘Things (with their fields)’…

  • Task
  • Task - text
  • Due Date - date
  • Completed - boolean
  • Parent Task - TASK
  • Folder - FOLDER
  • Priority - number
  • Tags - text
  • Folder
  • Name - text
  • Priority - number
  • Tasks - list of tasks

I’ve created a dropdown according to what I’ve watched in the video and read in the forums here so I’m sure it’s something simple I’ve missed regarding with how I’ve setup my data or configured the dropdown…

Here’s the current data set (so I should see two items in my dropdown)…

Any help would be greatly appreciated!

Have you tried using the debugger?

Interestingly enough, my debugger is not displaying. Hadn’t even noticed it was gone from the preview. I’ll try reloading the browser and see what it shows me.

If the URL doesn’t have “?debug_mode=true” at the end of it, it won’t show up. I’ve opened up the Preview a time or two and removed that little bit at the end of the URL to see what it looks like without the extra space, and forgotten to turn debug back on.

Not sure if that’s your issue, but thought I’d point it out.

1 Like

Thank you.

I tried switching between true/false but it’s still not showing up. I’ll probably have to reboot.

Are you pressing preview from the editor? the check also checks you actually own the app.

You probably don’t have this but just to double-check, do you have any constraints set up in the “Search for Folders”? I was thinking that if you had a constraint such as “Created By = Current User” that may be why it’s not showing up. If you created the folders within the App Data tab, instead of as a logged in user, then the “Created By” field is empty, and those folder results would not show up in preview.

1 Like

That is extremely insightful!

Actually I have roles created on the ‘Folder’ thing so that only the creator of that folder can see the folder (or search for) that was affecting my dropdown similarly to what you’ve described! (because I created the test data within the App Data tab instead of as a logged in user).

I changed the role setting for ‘Everyone Else’ to include ‘Find this in searches’ (I had deselected it) and it worked!

Thanks so much @fayewatson!

1 Like

Hi @emmanuel,

Yup, I was testing my dropdown in the previewer. Faye gave me the hint I needed. I had created roles when I was playing with autobinding but then abandoned it for a button instead and forgot about the roles.

Thanks for the reply!

Awesome!! :blush: My pleasure! I’ve done the exact same thing!

1 Like

@technoladie is there a template for what you created some where by chance?