[SOLVED] FB Login domain problem

Having a little difficulty setting up my Facebook login system. Currently, when clicking the button to sign up with facebook the button takes me to facebook and facebook displays the following:

“Can’t Load URL: The domain of this URL isn’t included in the app’s domains. To be able to load this URL, add all domains and subdomains of your app to the App Domains field in your app settings.”

Anyone run into this? Thanks


Nevermind, found the solution with a search

1 Like

What was it?

Had to match the site URL to the app domain in the facebook app settings.

1 Like

I’m just trying to add the Fbook login as an additional sign up/login option and am getting the same error message. Would we have to make our users whitelist the domain if they want to login through facebook??That’s not a realistic user experience…feels like there has to be a better way.

Hey - I’m having this problem and can’t figure out how to fix it. I’m brand new, so just playing around and figuring things out with a first basic app.

Here’s the URL: https://restity.bubbleapps.io/

Here’s the problem.

If I click on “log in with FB” button, here’s what I get.

However, when I got to Facebook developers, I put in the domain name, and I get the error below.

Any idea what the solution is?

I think the app domains should just be bubbleapps.io and what you currently have in there should be in the site url field.

@louisadekoya Thanks for your help. I tried those domains and they didn’t work. Any other idea?

I notice two differences between your screenshot and what I’ve got.

a) Mine just says bubbleapps.io in the app domain, so no www or even https. See below:

b) I have a website section on my settings page, where I put in my site url. I think in the step before you state whether your application is a native app or website. Following some instructions I saw somewhere, I chose website - if I recall correctly. Then in the Site URL field I specify my bubble app address e.g. https://myapp.bubbleapps.io/

I hope this helps.

click add platform down on the facebook app page then choose website then write your website same as like app domain bubbleapps.io then save


Hello @topherwilliams and @john2 have you manage to solve this issue? I am having the same error. Any thoughts? Thank you

I am having the same problem. Have tried all combinations of domain, subdomain, putting the URL in the website part, using full URL and URL root, with and without https. all combinations in the app domains as well.

Everything, and still getting the same error - it would be helpful if the people who have had this problem and then solved it, if they could just update here in a bit more detail what it was that made it work , please …

1 Like

Im having the same problem.
Has anyone solved this?

1 Like

Having the same problem here, any help would be appreciated

1 Like

Same issue here too! Would love to find a solution.

you can solve the domain problem using www. after http and before the actual name,
the problem i have is using facebook login with localhost, is it possible to test it locally? keep getting the same error you guys are getting!

Hey all! Man, this took me a while to figure out. If it’s not working after checking the steps above, make sure you’ve done these things:

  • Make the app public by going to “app review”
  • Make sure “Embedded Browser Oauth Login” is Yes

Solved it for me!


It solve my issue too, thanks for sharing.

Hi Guys… I was having this problem too, found another solution…

on Log into Facebook go to Products > Facebook Login, and set ‘Use Strict Mode for Redirect URIs’ to ‘No’ , and put your domain into ‘Valid OAuth redirect URIs’

See below for screenshots of all my settings… Hope this helps! (make sure to like this post!!)


This solved it perfectly! Thank you a lot!