Unable to login to Facebook

I followed the video and in the tutorial everything works successfully. However when I try this in my own app - logging in produces this error

Can’t Load URL: The domain of this URL isn’t included in the app’s domains. To be able to load this URL, add all domains and subdomains of your app to the App Domains field in your app settings.

Post March 2018 under Client OAuth Settings ‘Enfoce HTTPS’ and ‘Use Strict Mode for Redirect URIs’ must be enabled. Both are but I don’t know how to find the URL for my app so I can input it.

I did read the other articles but it appears that this is due to a new requirement and I don’t see guidance on this forum for it.

I found that link and it is no longer an error, but now the error is on my secret key

Error connecting to Facebook: Error validating client secret.

I’m running into the same error message from Facebook “Can’t Load URL: The domain name …”. Both “Enforce HTTPS” and “Use Strict Mode for Redirect URIs” are enabled.

On the Facebook Support they aren’t responding to the same problem. “It looks like you are using either a 3rd party library(Yakoyo) or the Facebook PHP SDK, unfortunately we do not support either of those implementations via this channel. If you are able to reproduce this issue using our JS SDK we can provide support.”

I welcome any suggestions.

I found a solution within the facebook for developers website. The area is the Products - Facebook Login - Settings. In the Valid OAuth Redirect URIs, I entered the URL for the page that handles the response from facebook: https://yelp-og.bubbleapps.io/version-test/signup?debug_mode=true and https://yelp-og.bubbleapps.io/version-test/signup. I’m doing Bubble training using Code-Free Startup and a recreation of a Yelp-like app that I call yelp-og.

I also used facebook’s Redirect URI Validator to make sure the URI’s were valid.

All of this is in a test environment. Once the app goes to production, these settings will need to reflect that.

This topic was automatically closed after 70 days. New replies are no longer allowed.