Forum Academy Marketplace Showcase Pricing Features

[Solved] Trouble using basic authentication with API

I put together a basic API of my own since I needed to create a separate data storage service for a lot of records. Everything is working great and am able to connect to it with everything except Bubble (API Connector). It uses basic authentication but when I set it up in Bubble, it gives me an error of ‘there was an issue setting up your call - Unauthorized’. I’ve tried to put in the user/pass a ton of different ways but no luck. I also have plenty of other calls working great, including others with basic authentication.

Has anyone else ran into this issue or have an idea why this might be happening? Any help is very much appreciated!

Mike

I’ll also add that I’ve tried putting the user/pass in the URL and using an auth token that I get back when I successfully connect with another application and both approaches get the same result.

Well, looks like it just needed to be encoded in base64. Referencing this post was helpful: [solved] Teamwork API Authentification

Thanks @NigelG and others on that post! I should have read that post more clearly the first time I was searching around :slight_smile:

Mike