Tatum API - Generate Private Key


I need some help with an API call.

I’m making an api call with the Bubble API Connector plugin, but the server responds with error code 400. See the settings below:

I need to call the Tatum API to generate Ethereum Private Key with POST and JSON methods, with two body parameters: “index” and “mnemonic”.

“mnemonic” is a 24-word phrase, and “index” is an integer between 0 and 2147483647. (by default I will use 0)

See the server’s response below:

"There was an issue setting up your call.

Raw response for the API

Status code 400
{“statusCode”:400,“errorCode”:“validation.failed”,“message”:“Request validation failed. Please see data for additional information.”,“data”:[“index must not be greater than 2147483647”, “index must not be less than 0”,“index must be an integer number”]}"

I tested the same call on the “Tatum API Reference” site, on the “REQBIN Online API Test” and on the “Postman”, always with the same “api-key” and the same “index” and “mnemonic” values, and in all they got the correct answer (“key”: [privatekey value]).

Only in Bubble.io I’m getting the response with error code 400.

How can I solve this problem?


Did you set header for content-type?
Probably application/json

Yes. The same error continues.

Can you share a screenshot of your settings?


See API configuration and testing screens.

API Connector configuration

I can generate the wallets, xpub, address, get the balance…

Private Key Configuration

Error generating private key.

Private key generation in Tatum (same api key and parameters)

Private key generation in ReqBin (same api key and parameters)

I appreciate your help.

Tengo el mismo problema o parecido al que presentas.

En mi caso lo pude resolver esta muy sencilla la solucion, habia elegido Txt y lo correcto es JSON, te comparto la imagen estimadisimo rodrigo7